请选择 进入手机版|继续访问电脑版

春江花月夜指标 通达信 副图 波段 无未来函数 短线 买卖点 抄底逃顶 趋势 操盘控盘

[复制链接]

admin  管理员

发表于 2018-4-24 09:00:15 | 查看全部

指标公式
软件: 通达信 
公式类型: 副图 
二级分类: 波段 无未来函数 短线 买卖点 抄底逃顶 趋势 操盘控盘 
春江花月夜指标 通达信 副图 波段 无未来函数 短线 买卖点 抄底逃顶 趋势 操盘控盘 炒股叉第6547张

春江花月夜指标 通达信 副图 波段 无未来函数 短线 买卖点 抄底逃顶 趋势 操盘控盘 炒股叉第6548张

[lywrap=通达信副图指标公式][lycode=tdx,true]{用法:春江花月夜   小花买入,红帆买入,春雪卖出。}
STICKLINE(1=1,0,-MACD,4,0),COLOR333300;
DI:=EMA(C,3)-EMA(C,13);
DE:=EMA(DI,9);
MACD:=2*(DI-DE)*10;
DI2:=EMA(C,5)-EMA(C,26);
DEA2:=EMA(DI2,9);
MACD2:=2*(DI2-DEA2)*10;
DIFF3:=EMA(C,7)-EMA(C,89);
DEA3:=EMA(DIFF3,21);
MACD3:=2*(DIFF3-DEA3)*10;
MMACD5:=MA(MACD3,3);
STICKLINE(1=1,0,REFDATE(LLV(-MACD3,1000),DATE),4,0),COLOR333300;
IF(MACD3<0,-MACD3,DRAWNULL)LINETHICK4,COLOR646400;
STICKLINE(MACD3<0,0,-MACD3,4,0),LINETHICK4,COLOR646400;
IF(MACD2<0,-MACD2,DRAWNULL)LINETHICK4,COLOR333333;
STICKLINE(MACD2<0,0,-MACD2,4,0),COLOR333333;
IF(MACD<0,-MACD,DRAWNULL)LINETHICK4,COLOR004444;
STICKLINE(MACD<0,0,-MACD,4,0),COLOR004444;

IF(MACD3>=0,MACD3,DRAWNULL)LINETHICK4,COLOR00CC00;
STICKLINE(MACD3>=0,0,MACD3,4,0),COLOR00CC00;
IF(MACD2>=0,MACD2,DRAWNULL)LINETHICK4,COLOR009900;
STICKLINE(MACD2>=0,0,MACD2,4,0),COLOR009900;
STICKLINE(MACD>=0,0,MACD,4,0),COLOR006600;

STICKLINE(MACD3>=0,0,-MACD3*0.8,4,0),COLOR666600;
STICKLINE(MACD2>=0,0,-MACD2*0.8,4,0),COLOR663300;
STICKLINE(MACD>=0,0,-MACD*0.8,4,0),COLOR333300;

小花:IF(MACD>=0 AND REF(MACD,1)<0,1,DRAWNULL),CROSSDOT,LINETHICK6,COLORFF33FF;
IF(MACD>=0 AND REF(MACD,1)<0,1,DRAWNULL),POINTDOT,LINETHICK4,COLOR00CCFF;
春雪:IF(CROSS(MMACD5,MACD3),MACD3*1.2,DRAWNULL),CROSSDOT,
LINETHICK2,COLORFFFFFF;
红帆:STICKLINE(CROSS(MACD3,MMACD5) AND MACD3<0,MACD3*1.1,MACD3*1.1-0.5,16,1),COLORFFFFFF;
STICKLINE(CROSS(MACD3,MMACD5) AND MACD3<0,MACD3*1.1+3,MACD3*1.1+0.3,8,0),
COLOR0000FF;
STICKLINE(CROSS(MACD3,MMACD5) AND MACD3<0,MACD3*1.1,MACD3*1.1+3.5,0.001,1),
COLORFFFFFF;
IF(MACD>=0,-9,DRAWNULL),COLORFFFF00,POINTDOT;
IF(MACD2>=0,-8,DRAWNULL),COLORFFFF00,POINTDOT;
IF(C>0,-7,-7),COLORFFFF00,POINTDOT;
IF(MACD3>0,-6,DRAWNULL),COLORFFFF00,POINTDOT;
IF(MACD3>0,-5,-5),COLORFFFF00,POINTDOT;
IF(C>0,-4,-4),COLORFFFF00,POINTDOT;
IF(MACD3>0,-3,DRAWNULL),COLORFFFF00,POINTDOT;
IF(MACD3>0,-2,DRAWNULL),COLORFFFF00,POINTDOT;
IF(C>0,-1,-1),COLORFFFF00,POINTDOT;[/lycode][lycode=tdx2,true]当满足条件1=1时,在0和-平滑异同平均位置之间画柱状线,宽度为4,0不为0则画空心柱.,COLOR333300
DI赋值:收盘价的3日指数移动平均-收盘价的13日指数移动平均
DE赋值:DI的9日指数移动平均
MACD赋值:2*(DI-DE)*10
DI2赋值:收盘价的5日指数移动平均-收盘价的26日指数移动平均
DEA2赋值:DI2的9日指数移动平均
MACD2赋值:2*(DI2-DEA2)*10
DIFF3赋值:收盘价的7日指数移动平均-收盘价的89日指数移动平均
DEA3赋值:DIFF3的21日指数移动平均
MACD3赋值:2*(DIFF3-DEA3)*10
MMACD5赋值:MACD3的3日简单移动平均
当满足条件1=1时,在0和日期日1000日内-MACD3的最低值位置之间画柱状线,宽度为4,0不为0则画空心柱.,COLOR333300
如果MACD3<0,返回-MACD3,否则返回无效数线宽为4,COLOR646400
当满足条件MACD3<0时,在0和-MACD3位置之间画柱状线,宽度为4,0不为0则画空心柱.,线宽为4,COLOR646400
如果MACD2<0,返回-MACD2,否则返回无效数线宽为4,COLOR333333
当满足条件MACD2<0时,在0和-MACD2位置之间画柱状线,宽度为4,0不为0则画空心柱.,COLOR333333
如果MACD<0,返回-MACD,否则返回无效数线宽为4,COLOR004444
当满足条件MACD<0时,在0和-MACD位置之间画柱状线,宽度为4,0不为0则画空心柱.,COLOR004444
如果MACD3>=0,返回MACD3,否则返回无效数线宽为4,COLOR00CC00
当满足条件MACD3>=0时,在0和MACD3位置之间画柱状线,宽度为4,0不为0则画空心柱.,COLOR00CC00
如果MACD2>=0,返回MACD2,否则返回无效数线宽为4,COLOR009900
当满足条件MACD2>=0时,在0和MACD2位置之间画柱状线,宽度为4,0不为0则画空心柱.,COLOR009900
当满足条件MACD>=0时,在0和MACD位置之间画柱状线,宽度为4,0不为0则画空心柱.,COLOR006600
当满足条件MACD3>=0时,在0和-MACD3*0.8位置之间画柱状线,宽度为4,0不为0则画空心柱.,COLOR666600
当满足条件MACD2>=0时,在0和-MACD2*0.8位置之间画柱状线,宽度为4,0不为0则画空心柱.,COLOR663300
当满足条件MACD>=0时,在0和-MACD*0.8位置之间画柱状线,宽度为4,0不为0则画空心柱.,COLOR333300
输出小花:如果MACD>=0ANDREF(MACD,1)<0,返回1,否则返回无效数,CROSSDOT,线宽为6,COLORFF33FF
如果MACD>=0ANDREF(MACD,1)<0,返回1,否则返回无效数,POINTDOT,线宽为4,COLOR00CCFF
输出春雪:如果MMACD5上穿MACD3,返回MACD3*1.2,否则返回无效数,CROSSDOT,线宽为2,COLORFFFFFF
输出红帆:当满足条件MACD3上穿MMACD5ANDMACD3<0时,在MACD3*1.1和MACD3*1.1-0.5位置之间画柱状线,宽度为16,1不为0则画空心柱.,COLORFFFFFF
当满足条件MACD3上穿MMACD5ANDMACD3<0时,在MACD3*1.1+3和MACD3*1.1+0.3位置之间画柱状线,宽度为8,0不为0则画空心柱.,COLOR0000FF
当满足条件MACD3上穿MMACD5ANDMACD3<0时,在MACD3*1.1和MACD3*1.1+3.5位置之间画柱状线,宽度为0.001,1不为0则画空心柱.,COLORFFFFFF
如果MACD>=0,返回-9,否则返回无效数,COLORFFFF00,POINTDOT
如果MACD2>=0,返回-8,否则返回无效数,COLORFFFF00,POINTDOT
如果收盘价>0,返回-7,否则返回-7,COLORFFFF00,POINTDOT
如果MACD3>0,返回-6,否则返回无效数,COLORFFFF00,POINTDOT
如果MACD3>0,返回-5,否则返回-5,COLORFFFF00,POINTDOT
如果收盘价>0,返回-4,否则返回-4,COLORFFFF00,POINTDOT
如果MACD3>0,返回-3,否则返回无效数,COLORFFFF00,POINTDOT
如果MACD3>0,返回-2,否则返回无效数,COLORFFFF00,POINTDOT
如果收盘价>0,返回-1,否则返回-1,COLORFFFF00,POINTDOT[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1H7OeTNL53TbS7gEae8OCuw

看了该指标的人还看了:
底部启动点指标    短线反弹指标
超级主力建仓指标    底部建仓指标

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表