指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 无未来函数 买卖点 
TIM截图20180411114207.png

TIM截图20180411114215.png

[lywrap=通达信主图指标公式][lycode=tdx,true]MA5:EMA(CLOSE,5);
MA10:EMA(C,10);
MA20:EMA(CLOSE,20);
VAR1:=(REF(HIGH,1)+REF(LOW,1))/2;
压力线:=MA(CLOSE,20)+2*STD(CLOSE,20);
支撑线:=MA(CLOSE,21)-2.2*STD(CLOSE,21);
VAR2:=CROSS(VAR1,压力线);
VAR3:=REF(CLOSE,1);
VAR4:=SMA(MAX(CLOSE-VAR3,0),7,1)/SMA(ABS(CLOSE-VAR3),7,1)*100;
VAR5:=CROSS(79,VAR4);
VAR6:=FILTER(VAR5,4);
DRAWICON(FILTER(VAR6 OR VAR2,5),HIGH,2);
VAR7:=FILTER( MA5>REF(MA5,1)AND MA10>REF(MA10,1)AND MA20>REF(MA20,1)AND MA5<MA10,5);
VAR8:=FILTER(HHVBARS(H,13)/C>2 AND MA5>REF(MA5,1)AND MA5<MA10,7);
VAR9:=REF(L,2)<支撑线 AND L>支撑线 AND C>O AND MA5>REF(MA5,1);
DRAWICON(FILTER(VAR7 OR VAR8 OR VAR9,5)AND VAR4<45,L,1);[/lycode][lycode=tdx2,true]输出MA5:收盘价的5日指数移动平均
输出MA10:收盘价的10日指数移动平均
输出MA20:收盘价的20日指数移动平均
VAR1赋值:(1日前的最高价+1日前的最低价)/2
压力线赋值:收盘价的20日简单移动平均+2*收盘价的20日估算标准差
支撑线赋值:收盘价的21日简单移动平均-2.2*收盘价的21日估算标准差
VAR2赋值:VAR1上穿压力线
VAR3赋值:1日前的收盘价
VAR4赋值:收盘价-VAR3和0的较大值的7日[1日权重]移动平均/收盘价-VAR3的绝对值的7日[1日权重]移动平均*100
VAR5赋值:79上穿VAR4
VAR6赋值:VAR5的4日过滤
当满足条件VAR6ORVAR2的5日过滤时,在最高价位置画2号图标
VAR7赋值:MA5>1日前的MA5ANDMA10>1日前的MA10ANDMA20>1日前的MA20ANDMA5<MA10的5日过滤
VAR8赋值:13日内最高价距今天数/收盘价>2ANDMA5>1日前的MA5ANDMA5<MA10的7日过滤
VAR9赋值:2日前的最低价<支撑线 AND 最低价>支撑线 AND 收阳线AND MA5>1日前的MA5
当满足条件VAR7ORVAR8ORVAR9的5日过滤ANDVAR4<45时,在最低价位置画1号图标[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1xhZvLN6208XkVVm5OOke5A

看了该指标的人还看了:
高抛低吸指标    主力吸筹指标    校长抓黑马指标
短线操盘指标    趋势买卖控盘指标    牛起步指标

使用道具 举报

回复