指标公式
软件: 通达信 
公式类型: 副图 
二级分类: 无未来函数 买卖点 抄底逃顶 
TIM截图20180411113512.png

TIM截图20180411113532.png

[lywrap=通达信副图指标公式][lycode=tdx,true]{参数N 2.00,100.00,26.00}
N:=26;
VAR1:=EMA(HHV(HIGH,500),21);
VAR2:=EMA(HHV(HIGH,250),21);
VAR3:=EMA(HHV(HIGH,90),21);
VAR4:=EMA(LLV(LOW,500),21);
VAR5:=EMA(LLV(LOW,250),21);
VAR6:=EMA(LLV(LOW,90),21);
VAR7:=EMA((VAR4*0.96+VAR5*0.96+VAR6*0.96+VAR1*0.558+VAR2*0.558+VAR3*0.558)/6,21);
VAR8:=EMA((VAR4*1.25+VAR5*1.23+VAR6*1.2+VAR1*0.55+VAR2*0.55+VAR3*0.65)/6,21);
VAR9:=EMA((VAR4*1.3+VAR5*1.3+VAR6*1.3+VAR1*0.68+VAR2*0.68+VAR3*0.68)/6,21);
VARA:=EMA((VAR7*3+VAR8*2+VAR9)/6*1.738,21);
VARB:=REF(LOW,1); VARC:=SMA(ABS(LOW-VARB),3,1)/SMA(MAX(LOW-VARB,0),3,1)*100;
VARD:=EMA(IF(CLOSE*1.35<=VARA,VARC*10,VARC/10),3);
VARE:=LLV(LOW,30);
VARF:=HHV(VARD,30);
VAR10:=IF(MA(CLOSE,58),1,0);
MID:=REF(HIGH+LOW,1)/2;
CR:SUM(MAX(0,HIGH-MID),N)/SUM(MAX(0,MID-LOW),N)*100,COLORWHITE;
VAR12:=SUM(MAX(0,HIGH-MID),N)/SUM(MAX(0,MID-LOW),N)*100;
VAR11:=EMA(IF(LOW<=VARE,(VARD+VARF*2)/2,0),3)/618*VAR10;
出击:IF(VAR12<60 AND VAR11>10,6000/VAR12,0),COLORRED;
攻击:IF (VAR11>20,VAR11*3,0),COLORYELLOW;[/lycode][lycode=tdx2,true]N赋值:26
VAR1赋值:500日内最高价的最高值的21日指数移动平均
VAR2赋值:250日内最高价的最高值的21日指数移动平均
VAR3赋值:90日内最高价的最高值的21日指数移动平均
VAR4赋值:500日内最低价的最低值的21日指数移动平均
VAR5赋值:250日内最低价的最低值的21日指数移动平均
VAR6赋值:90日内最低价的最低值的21日指数移动平均
VAR7赋值:(VAR4*0.96+VAR5*0.96+VAR6*0.96+VAR1*0.558+VAR2*0.558+VAR3*0.558)/6的21日指数移动平均
VAR8赋值:(VAR4*1.25+VAR5*1.23+VAR6*1.2+VAR1*0.55+VAR2*0.55+VAR3*0.65)/6的21日指数移动平均
VAR9赋值:(VAR4*1.3+VAR5*1.3+VAR6*1.3+VAR1*0.68+VAR2*0.68+VAR3*0.68)/6的21日指数移动平均
VARA赋值:(VAR7*3+VAR8*2+VAR9)/6*1.738的21日指数移动平均
VARB赋值:1日前的最低价
VARC赋值:最低价-VARB的绝对值的3日[1日权重]移动平均/最低价-VARB和0的较大值的3日[1日权重]移动平均*100
VARD赋值:如果收盘价*1.35<=VARA,返回VARC*10,否则返回VARC/10的3日指数移动平均
VARE赋值:30日内最低价的最低值
VARF赋值:30日内VARD的最高值
VAR10赋值:如果收盘价的58日简单移动平均,返回1,否则返回0
MID赋值:1日前的最高价+最低价/2
输出带状能量线:0和最高价-MID的较大值的N日累和/0和MID-最低价的较大值的N日累和*100,画白色
VAR12赋值:0和最高价-MID的较大值的N日累和/0和MID-最低价的较大值的N日累和*100
VAR11赋值:如果最低价<=VARE,返回(VARD+VARF*2)/2,否则返回0的3日指数移动平均/618*VAR10
输出出击:如果VAR12<60ANDVAR11>10,返回6000/VAR12,否则返回0,画红色
输出攻击:如果VAR11>20,返回VAR11*3,否则返回0,画黄色[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1dR93CK-uPIstIQj05GtM2A

看了该指标的人还看了:
高抛低吸指标    主力吸筹指标    校长抓黑马指标
短线操盘指标    趋势买卖控盘指标    牛起步指标

使用道具 举报

回复