请选择 进入手机版|继续访问电脑版

波浪买卖线指标 通达信 主图 波段 买卖点 画线 趋势 操盘控盘

[复制链接]

admin  管理员

发表于 2018-4-15 09:00:22 | 查看全部

指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 波段 买卖点 画线 趋势 操盘控盘 
波浪买卖线
上穿卖线买,下穿卖线卖。红持股,蓝持币,黄提醒。
指标用到ZIG未来函数,但不影响指标的买卖判断,,未来函数只是提示一下高低转折点给你做参考,若对未来函数忌讳者请绕开。

波浪买卖线指标 通达信 主图 波段 买卖点 画线 趋势 操盘控盘 炒股叉第6359张

波浪买卖线指标 通达信 主图 波段 买卖点 画线 趋势 操盘控盘 炒股叉第6360张

[lywrap=通达信主图指标公式][lycode=tdx,true]GET:ZIG(3,5),COLORRED;
PL5:=ZIG(3,5);
EN1:=PL5>REF(PL5,1) AND REF(PL5,1)<=REF(PL5,2) AND REF(PL5,2)<=REF(PL5,3);
EX1:=PL5<REF(PL5,1) AND REF(PL5,1)>=REF(PL5,2) AND REF(PL5,2)>=REF(PL5,3);
PL10:=ZIG(3,10);
EN2:=PL10>REF(PL10,1) AND REF(PL10,1)<=REF(PL10,2) AND REF(PL10,2)<=REF(PL10,3);
EX2:=PL10<REF(PL10,1) AND REF(PL10,1)>=REF(PL10,2) AND REF(PL10,2)>=REF(PL10,3);
PL20:=ZIG(3,20);
EN3:=PL20>REF(PL20,1) AND REF(PL20,1)<=REF(PL20,2) AND REF(PL20,2)<=REF(PL20,3);
EX3:=PL20<REF(PL20,1) AND REF(PL20,1)>=REF(PL20,2) AND REF(PL20,2)>=REF(PL20,3);
走强1:=BARSLAST(PL5<REF(PL5,1));
走弱1:=BARSLAST(PL5>REF(PL5,1));
走强2:=BARSLAST(PL10<REF(PL10,1));
走弱2:=BARSLAST(PL10>REF(PL10,1));
走强3:=BARSLAST(PL20<REF(PL20,1));
走弱3:=BARSLAST(PL20>REF(PL20,1));
ZTJZ5:=IF(PL10>REF(PL10,1),COUNT(EN1,走强2),0);
ZTJD5:=IF(PL10>REF(PL10,1),COUNT(EX1,走强2),0);
DTJZ5:=IF(PL10<REF(PL10,1),COUNT(EN1,走弱2),0);
DTJD5:=IF(PL10<REF(PL10,1),COUNT(EX1,走弱2),0);
ZTJZ10:=IF(PL20>REF(PL20,1),COUNT(EN2,走强3),0);
ZTJD10:=IF(PL20>REF(PL20,1),COUNT(EX2,走强3),0);
DTJZ10:=IF(PL20<REF(PL20,1),COUNT(EN2,走弱3),0);
DTJD10:=IF(PL20<REF(PL20,1),COUNT(EX2,走弱3),0);
买线:EMA(C,2),COLORRED;
卖线:EMA(SLOPE(C,21)*20+C,42),COLORYELLOW;
BU:=CROSS(买线,卖线);
SEL:=CROSS(卖线,买线);
STICKLINE(买线>=卖线,LOW,HIGH,0.1,1),COLORRED;
STICKLINE(买线>=卖线,CLOSE,OPEN,3,1),COLORRED;
STICKLINE(买线>=卖线,CLOSE,OPEN,3,1),COLORRED;
STICKLINE(买线<卖线,CLOSE,OPEN,3,0),COLORBLUE;
STICKLINE(买线<卖线,CLOSE,OPEN,3,0),COLORBLUE;
STICKLINE(买线<卖线,LOW,HIGH,0.1,1),COLORBLUE;
STICKLINE(CROSS(买线,卖线) OR CROSS(卖线,买线),OPEN,CLOSE,3,0),COLORYELLOW;[/lycode][lycode=tdx2,true]输出GET:收盘价5%的之字转向,画红色
PL5赋值:收盘价5%的之字转向
EN1赋值:PL5>1日前的PL5 AND 1日前的PL5<=2日前的PL5 AND 2日前的PL5<=3日前的PL5
EX1赋值:PL5<1日前的PL5 AND 1日前的PL5>=2日前的PL5 AND 2日前的PL5>=3日前的PL5
PL10赋值:收盘价10%的之字转向
EN2赋值:PL10>1日前的PL10 AND 1日前的PL10<=2日前的PL10 AND 2日前的PL10<=3日前的PL10
EX2赋值:PL10<1日前的PL10 AND 1日前的PL10>=2日前的PL10 AND 2日前的PL10>=3日前的PL10
PL20赋值:收盘价20%的之字转向
EN3赋值:PL20>1日前的PL20 AND 1日前的PL20<=2日前的PL20 AND 2日前的PL20<=3日前的PL20
EX3赋值:PL20<1日前的PL20 AND 1日前的PL20>=2日前的PL20 AND 2日前的PL20>=3日前的PL20
走强1赋值:上次PL5<1日前的PL5距今天数
走弱1赋值:上次PL5>1日前的PL5距今天数
走强2赋值:上次PL10<1日前的PL10距今天数
走弱2赋值:上次PL10>1日前的PL10距今天数
走强3赋值:上次PL20<1日前的PL20距今天数
走弱3赋值:上次PL20>1日前的PL20距今天数
ZTJZ5赋值:如果PL10>1日前的PL10,返回统计走强2日中满足EN1的天数,否则返回0
ZTJD5赋值:如果PL10>1日前的PL10,返回统计走强2日中满足EX1的天数,否则返回0
DTJZ5赋值:如果PL10<1日前的PL10,返回统计走弱2日中满足EN1的天数,否则返回0
DTJD5赋值:如果PL10<1日前的PL10,返回统计走弱2日中满足EX1的天数,否则返回0
ZTJZ10赋值:如果PL20>1日前的PL20,返回统计走强3日中满足EN2的天数,否则返回0
ZTJD10赋值:如果PL20>1日前的PL20,返回统计走强3日中满足EX2的天数,否则返回0
DTJZ10赋值:如果PL20<1日前的PL20,返回统计走弱3日中满足EN2的天数,否则返回0
DTJD10赋值:如果PL20<1日前的PL20,返回统计走弱3日中满足EX2的天数,否则返回0
输出买线:收盘价的2日指数移动平均,画红色
输出卖线:收盘价的21日线性回归斜率*20+收盘价的42日指数移动平均,画黄色
BU赋值:买线上穿卖线
SEL赋值:卖线上穿买线
当满足条件买线>=卖线时,在最低价和最高价位置之间画柱状线,宽度为0.1,1不为0则画空心柱.,画红色
当满足条件买线>=卖线时,在收盘价和开盘价位置之间画柱状线,宽度为3,1不为0则画空心柱.,画红色
当满足条件买线>=卖线时,在收盘价和开盘价位置之间画柱状线,宽度为3,1不为0则画空心柱.,画红色
当满足条件买线<卖线时,在收盘价和开盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,画蓝色
当满足条件买线<卖线时,在收盘价和开盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,画蓝色
当满足条件买线<卖线时,在最低价和最高价位置之间画柱状线,宽度为0.1,1不为0则画空心柱.,画蓝色
当满足条件买线上穿卖线ORCROSS(卖线,买线)时,在开盘价和收盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,画黄色[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1yUVLWeAhZmcv9eNmERsh8w

看了该指标的人还看了:
超短线指标    平台突破指标
波段买卖指标    主力筹码指标

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表