请选择 进入手机版|继续访问电脑版

机散动向指标 通达信 分时副图 买卖点 操盘控盘

[复制链接]

admin  管理员

发表于 2018-4-15 09:00:22 | 查看全部

指标公式
软件: 通达信 
公式类型: 分时副图 
二级分类: 买卖点 操盘控盘 
机散动向指标 通达信 分时副图 买卖点 操盘控盘 炒股叉第6339张

机散动向指标 通达信 分时副图 买卖点 操盘控盘 炒股叉第6340张

[lywrap=通达信分时副图指标公式][lycode=tdx,true]A1:=SUM(IF(CLOSE>REF(CLOSE,1),VOL/CAPITAL*100,IF(CLOSE<REF(CLOSE,1),-VOL/CAPITAL*100,0)),0);
成交额:=V*C/100,NODRAW;
A2:=SUM((IF(((成交额/8>20) AND (CLOSE>(REF(CLOSE,1)))),成交额,0)),0);
A3:=SUM((IF(((成交额/8>20) AND (CLOSE<(REF(CLOSE,1)))),成交额,0)),0);
A4:=SUM((IF(((成交额/8<20) AND (CLOSE>(REF(CLOSE,1)))),成交额,0)),0);
A5:=SUM((IF(((成交额/8<20) AND (CLOSE<(REF(CLOSE,1)))),成交额,0)),0);
A6:=((A2+A3)+A4)+A5;
A7:=IF((ISLASTBAR),((100*A2)/A6),0);
A8:=IF((ISLASTBAR),((100*A3)/A6),0);
A9:=IF((ISLASTBAR),((100*A4)/A6),0);
A10:=IF((ISLASTBAR),((100*A5)/A6),0);

机构买:(A2),LINETHICK6,COLORRED;
机构卖:(A3),LINETHICK6,COLORGREEN;
机构进出:=机构买-机构卖,NODRAW;
散户买:(A4),COLOR5555FF;
散户卖:(A5),COLOR55FF55;
强势:=((100*A2)/A6>50);
STICKLINE(强势,机构买*1.02,机构买*1.1,1,0),COLORYELLOW;
拉升:=((100*A2)/A6-(100*A3)/A6)>18 AND (100*A2)/A6-(100*A5)/A6>18;
STICKLINE(拉升,机构买*1.1,机构买*1.2,1,0),COLORCC00FF;
DRAWTEXT(ISLASTBAR=1,机构买*0.95,'●'),LINETHICK2,COLORRED;
DRAWTEXT(ISLASTBAR=1,机构卖*0.95,'○'),LINETHICK2,COLORFFFF55;
DRAWTEXT(机构进出>0 AND REF(机构进出,1)<=0,机构买*1.02,'●机买'),COLORMAGENTA;
DRAWTEXT(机构进出<0 AND REF(机构进出,1)>=0,机构买*0.98,'○机卖'),COLORFFFF55;
Q:=BETWEEN(C/(SUM(AMOUNT,BARSCOUNT(C))/SUM(VOL*100,BARSCOUNT(C))),1.05,0.95);
Q2:=IF(Q=0,MA(C,BARSCOUNT(C)),(SUM(AMOUNT,BARSCOUNT(C))/SUM(VOL*100,BARSCOUNT(C))));
DRAWICON(CROSS((C/Q2),1.03),机构买,5);

DD1:=1;
AAA1:=STRCAT(STRCAT('机构买入',CON2STR((100*A2)/A6,0)),'%');
AAA2:=STRCAT(STRCAT('机构卖出',CON2STR((100*A3)/A6,0)),'%');
AAA0:=STRCAT(STRCAT('机构总买入',CON2STR((100*(A2-A3))/A6,0)),'%');
AAA3:=STRCAT(STRCAT('散户买入',CON2STR((100*A4)/A6,0)),'%');
AAA4:=STRCAT(STRCAT('散户卖出',CON2STR((100*A5)/A6,0)),'%');
AAA5:=STRCAT(STRCAT('散户总买入',CON2STR((100*(A4-A5))/A6,0)),'%');
DRAWTEXT_FIX(DD1=1,0.200,1.00,0,AAA1),COLORRED;
DRAWTEXT_FIX(DD1=1,0.350,1.00,0,AAA2),COLORGREEN;
DRAWTEXT_FIX(DD1=1,0.500,1.00,0,AAA3),COLOR5555FF;
DRAWTEXT_FIX(DD1=1,0.650,1.00,0,AAA4),COLORGREEN;
DRAWTEXT_FIX(DD1=1,0.300,0.00,0,AAA0),LINETHICK5,COLORYELLOW;
DRAWTEXT_FIX(DD1=1,0.500,0.00,0,AAA5),LINETHICK5,COLORCYAN;


资金流入:=A2+A4,COLORRED,NODRAW;
资金流出:=A3+A5,NODRAW;
资金:=资金流入-资金流出,COLORYELLOW;
资金差:资金流入-资金流出,COLORYELLOW;

WW:=资金>0;
QQ:=资金<0;
STICKLINE(资金 AND WW,资金,0,0.0011,0),COLORRED;
STICKLINE(资金 AND QQ,资金,0,0.0011,0),COLORCYAN;

换手:=VOL/CAPITAL*100;
主动买盘:=BUYVOL,COLORLIRED,NODRAW;
主动卖盘:=SELLVOL,COLORLIBLUE,NODRAW;
买卖总量:=BUYVOL+SELLVOL,COLORYELLOW,NODRAW;
主动买比%:BUYVOL/买卖总量*100,COLORRED;
主动卖比%:SELLVOL/买卖总量*100,COLORGREEN;
{DRAWRECTREL(225,30,465,118,RGB(0,0,255));
DRAWRECTREL(225,30,225+2.4*CONST(主动买盘%),118,RGB(255,0,0));
DRAWTEXT_FIX(1,0.108,0.03,0,STRCAT(STRCAT('主动买盘',CON2STR(主动买盘%,2)),'%')),COLORYELLOW;
DRAWTEXT_FIX(1,0.48,0.03,0,STRCAT(STRCAT('主动卖盘',CON2STR(主动卖盘%,2)),'%')),COLORGREEN;
BB:=0,COLORWHITE;};[/lycode][lycode=tdx2,true]A1赋值:如果收盘价>1日前的收盘价,返回成交量(手)/当前流通股本(手)*100,否则返回如果收盘价<1日前的收盘价,返回-成交量(手)/当前流通股本(手)*100,否则返回0的历史累和
成交额赋值:成交量(手)*收盘价/100,NODRAW
A2赋值:(如果((成交额/8>20)AND(收盘价>(1日前的收盘价))),返回成交额,否则返回0)的历史累和
A3赋值:(如果((成交额/8>20)AND(收盘价<(1日前的收盘价))),返回成交额,否则返回0)的历史累和
A4赋值:(如果((成交额/8<20)AND(收盘价>(1日前的收盘价))),返回成交额,否则返回0)的历史累和
A5赋值:(如果((成交额/8<20)AND(收盘价<(1日前的收盘价))),返回成交额,否则返回0)的历史累和
A6赋值:((A2+A3)+A4)+A5
A7赋值:如果(是否最后一个周期),返回((100*A2)/A6),否则返回0
A8赋值:如果(是否最后一个周期),返回((100*A3)/A6),否则返回0
A9赋值:如果(是否最后一个周期),返回((100*A4)/A6),否则返回0
A10赋值:如果(是否最后一个周期),返回((100*A5)/A6),否则返回0
输出机构买:(A2),线宽为6,画红色
输出机构卖:(A3),线宽为6,画绿色
机构进出赋值:机构买-机构卖,NODRAW
输出散户买:(A4),COLOR5555FF
输出散户卖:(A5),COLOR55FF55
强势赋值:((100*A2)/A6>50)
当满足条件强势时,在机构买*1.02和机构买*1.1位置之间画柱状线,宽度为1,0不为0则画空心柱.,画黄色
拉升赋值:((100*A2)/A6-(100*A3)/A6)>18 AND (100*A2)/A6-(100*A5)/A6>18
当满足条件拉升时,在机构买*1.1和机构买*1.2位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLORCC00FF
当满足条件是否最后一个周期=1时,在机构买*0.95位置书写文字,线宽为2,画红色
当满足条件是否最后一个周期=1时,在机构卖*0.95位置书写文字,线宽为2,COLORFFFF55
当满足条件机构进出>0ANDREF(机构进出,1)<=0时,在机构买*1.02位置书写文字,画洋红色
当满足条件机构进出<0ANDREF(机构进出,1)>=0时,在机构买*0.98位置书写文字,COLORFFFF55
Q赋值:收盘价/(成交额(元)的收盘价的有效数据周期数日累和/成交量(手)*100的收盘价的有效数据周期数日累和)位于1.05和0.95之间
Q2赋值:如果Q=0,返回收盘价的收盘价的有效数据周期数日简单移动平均,否则返回(成交额(元)的收盘价的有效数据周期数日累和/成交量(手)*100的收盘价的有效数据周期数日累和)
当满足条件(收盘价/Q2)上穿1.03时,在机构买位置画5号图标
DD1赋值:1
AAA1赋值:字符串相加
AAA2赋值:字符串相加
AAA0赋值:字符串相加
AAA3赋值:字符串相加
AAA4赋值:字符串相加
AAA5赋值:字符串相加
当满足条件DD1=1时,在横轴0.200纵轴1.00位置书写文字,画红色
当满足条件DD1=1时,在横轴0.350纵轴1.00位置书写文字,画绿色
当满足条件DD1=1时,在横轴0.500纵轴1.00位置书写文字,COLOR5555FF
当满足条件DD1=1时,在横轴0.650纵轴1.00位置书写文字,画绿色
当满足条件DD1=1时,在横轴0.300纵轴0.00位置书写文字,线宽为5,画黄色
当满足条件DD1=1时,在横轴0.500纵轴0.00位置书写文字,线宽为5,画青色
资金流入赋值:A2+A4,画红色,NODRAW
资金流出赋值:A3+A5,NODRAW
资金赋值:资金流入-资金流出,画黄色
输出资金差:资金流入-资金流出,画黄色
WW赋值:资金>0
QQ赋值:资金<0
当满足条件资金ANDWW时,在资金和0位置之间画柱状线,宽度为0.0011,0不为0则画空心柱.,画红色
当满足条件资金ANDQQ时,在资金和0位置之间画柱状线,宽度为0.0011,0不为0则画空心柱.,画青色
换手赋值:成交量(手)/当前流通股本(手)*100
主动买盘赋值:外盘,画淡红色,NODRAW
主动卖盘赋值:内盘,画淡蓝色,NODRAW
买卖总量赋值:外盘+内盘,画黄色,NODRAW
输出主动买比%:外盘/买卖总量*100,画红色
输出主动卖比%:内盘/买卖总量*100,画绿色[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1n-H5jZrxJSGkvQuo4Xo8fQ

看了该指标的人还看了:
自动波浪指标    梦狼操作系统指标
牛逼买入指标    抄底神剑指标

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表