请选择 进入手机版|继续访问电脑版

高盈利指标,年盈利必上80% 通达信 主图 波段 无未来函数 买卖点 操盘控盘

[复制链接]

admin  管理员

发表于 2018-4-14 09:00:14 | 查看全部

指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 波段 无未来函数 买卖点 操盘控盘 
高盈利指标,年盈利必上80% 通达信 主图 波段 无未来函数 买卖点 操盘控盘 炒股叉第6325张

高盈利指标,年盈利必上80% 通达信 主图 波段 无未来函数 买卖点 操盘控盘 炒股叉第6326张

[lywrap=通达信主图指标公式][lycode=tdx,true]{参数 D : 34,90,72 }
D:=72;
压力: BBI+3*STD(BBI,10),LINETHICK0;
支撑: BBI-3*STD(BBI,10),LINETHICK0;
{安全线: MA(CLOSE,30), CIRCLEDOT;}
VARF:=(2*CLOSE+HIGH+LOW)/4;
VA4:=LLV(LOW,34);
VA5:=HHV(HIGH,34);
VA6:=EMA((VARF-VA4)/(VA5-VA4)*100,6);
VA7:=EMA(0.667*REF(VA6,1)+0.333*VA6,4);
DRAWTEXT(IF(COUNT(CLOSE<REF(CLOSE,1),8)/8>0.3 AND COUNT(VA6>VA7,3) AND REF(LOW,1)=LLV(LOW,120) AND
CLOSE>OPEN,1,0),L*0.94,'出击'),COLORYELLOW;
VAR27:=REF(CLOSE,1);
VAR28:=SMA(MAX(CLOSE-VAR27,0),5.5,1)/SMA(ABS(CLOSE-VAR27),6,1)*100;
DRAWICON((IF(CROSS(76,VAR28),1,0)) OR CROSS(70,RSI),H*1.01,2);
DRAWICON((IF(CROSS(VAR28,21),1,0)),L*0.97,1);
DRAWTEXT((IF(CROSS(76,VAR28),1,0)) OR CROSS(84,RSI),H*1.03,'莫贪') ,COLORYELLOW;
股价:MA(C,3),COLORGREEN,LINETHICK2;
B:=股价<REF(股价,1);
短线:IF(B-1,股价,DRAWNULL)COLORMAGENTA,LINETHICK2;
VAR4A:=EMA(CLOSE,3);
DRAWICON(COUNT(REF(VAR4A,1)<REF(VAR4A,2),5)=5 AND VAR4A>REF(VAR4A,1),L*0.98,4);
DRAWTEXT(COUNT(REF(VAR4A,1)<REF(VAR4A,2),5)=5 AND VAR4A>REF(VAR4A,1),L*0.96,'出手');
弱: IF(MA(CLOSE,13)>SMA(LOW,13,2)*1.01,SMA(LOW,13,2)*1.01,SMA(LOW,13,2)*1.01),COLORWHITE,LINETHICK1;
强:IF(SMA(LOW,13,2)*1.01>=REF(SMA(LOW,13,2)*1.01,1),SMA(LOW,13,2)*1.01,DRAWNULL),COLORRED,LINETHICK1;
VAR32:=100-3*SMA((CLOSE-LLV(LOW,D))/(HHV(HIGH,D)-LLV(LOW,D))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,D))/(HHV(HIGH,D)-LLV(LOW,D))*100,20,1),15,1);
VAR33:=100-3*SMA((OPEN-LLV(LOW,D))/(HHV(HIGH,D)-LLV(LOW,D))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,D))/(HHV(HIGH,D)-LLV(LOW,D))*100,20,1),15,1);
VAR2F:=VAR32<REF(VAR33,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
DRAWTEXT(VAR2F AND COUNT(VAR2F,30)=1,L*0.99,'大资金进场'),COLORMAGENTA;
顶部:HHV(HIGH,19),LINETHICK1,COLORGREEN;
底部:LLV(LOW,19),LINETHICK1,COLOR0099FF;
EMA7:=EMA(C,7);
EMA13:=EMA(C,13);
EMA34:=EMA(C,34);
EMA55:=EMA(C,55);
EMA120:=EMA(C,120);
CR1:=(C-REF(C,1))/REF(C,1)*100>0.5;
CR2:=V>MA(V,5)*0.6;
CR3:=COUNT(CROSS(EMA13,EMA55),3)=1;
CR4:=ABS(EMA34-EMA55)/EMA55<0.03;
CR5:=EMA55<=EMA120 AND EMA55>=REF(EMA55,1);
CR6:=FILTER(CR1 AND CR2 AND CR3 AND CR4 AND CR5,2);
DRAWTEXT(CROSS(EMA7,EMA13),H*1.01,'弱势当心'),COLORF00FF0;
DRAWTEXT(CROSS(EMA7,EMA34),H*1.02,'注意');
DRAWTEXT(CROSS(EMA13,EMA34),H*1.03,'危险'),COLORF00FF0;
DRAWTEXT(CR6,H*1.01,'明高卖'),COLORF00FF0;
SAT:=IF((AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100>100,100,(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100);
AA10:=MA(CLOSE,8),COLOR0000FF;
AA12:=MA(CLOSE,12),COLOR0000FF;
BB10:=((ATAN((AA10 - REF(AA10,1))) * 3.1416) * 10);
BB12:=((ATAN((AA12 - REF(AA12,1))) * 3.1416) * 10);
MA13:=MA(CLOSE,13);
X1:=(C+L+H)/3;BB13:=ATAN(EMA(X1,13)-REF(EMA(X1,13),1))*3.1416*10;
EMA8:=EMA(C,8);
DRAWTEXT(FILTER(BB13>1 AND EMA(X1,13)>REF(EMA(X1,8),1),10),EMA8,'∠45上升'),COLORWHITE;
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
V1:=EMA(CLOSE,5);
V2:=EMA(EMA(CLOSE,90)*1.01,10);
DRAWTEXT(CROSS(V1,V2),V1+0.05,'牛起步'),COLOR00FF00;
VAR2AA:=MA(C,2);
VAR3AA:=IF((CLOSE>REF(CLOSE,1)),88,0);
VAR4AA:=IF(((CLOSE)/(REF(CLOSE,1))>1.05) AND ((HIGH)/(CLOSE)<1.01) AND (VAR3AA>0),91,0);
DRAWTEXT(FILTER((VAR4AA>90),45) AND (UPNDAY(VAR2AA,1)),(LOW)*(0.97),'大胆搏 '),COLORRED;
AAC:=CLOSE/REF(CLOSE,1)>=1.09;
DRAWTEXT(AAC,LOW*0.97,'追'), COLORYELLOW;
STICKLINE(AAC,OPEN,CLOSE,2,0),COLORYELLOW;
STICKLINE(AAC,LOW,HIGH,0,0 ),COLORYELLOW;
平衡:=SMA(EMA(SMA((CLOSE+LOW)/2,3,1),3),5,1);
限制:=EMA((((HIGH+CLOSE)/2+LOW+(CLOSE+LOW)/2)/3-EMA(LLV(((HIGH+CLOSE) /2+LOW+(CLOSE+LOW)/2)/3,89),2))/(EMA(HHV (((HIGH+CLOSE)/2+LOW+(CLOSE+LOW)/2)/3,21),2)-EMA(LLV(((HIGH+CLOSE)/2+LOW+(CLOSE+LOW)/2)/3,89),2)),8)*100;
{DRAWICON(FILTER(平衡>REF(平衡,1)AND HHV(MA((HIGH+CLOSE)/2,13),10)<REF(HHV(MA((HIGH+CLOSE)/2,13),10),1)AND((CLOSE+LOW)/2)>REF((CLOSE+LOW)/2,1),5)AND 限制<88,LOW*0.98,5);}
DRAWTEXT(FILTER(平衡>REF(平衡,1)AND HHV(MA((HIGH+CLOSE)/2,13),10)<REF(HHV(MA((HIGH+CLOSE)/2,13),10),1)AND((CLOSE+LOW)/2)>REF((CLOSE+LOW)/2,1),5)AND 限制<88,LOW*0.95,'放心追涨'),,COLORFFFF33;
YC_买进:=((CLOSE-REF(MA(CLOSE,6),1))/6+MA(CLOSE,6))*1.004;
买进条件:=CROSS(CLOSE,YC_买进) AND YC_买进>REF(YC_买进,1),LINETHICK0;
YC_加仓:=((CLOSE-REF(MA(CLOSE,18),1))/18+MA(CLOSE,18))*1.004;
加仓条件:=CROSS(CLOSE,YC_加仓) AND YC_加仓>REF(YC_加仓,1),LINETHICK0;
DRAWTEXT(买进条件 AND 加仓条件,L*0.98,'满仓');
AAA:=(3*C+H+L+O)/6;
VAR41:=(8*AAA+7*REF(AAA,1)+6*REF(AAA,2)+5*REF(AAA,3)+4*REF(AAA,4)+3*REF(AAA,5)+2*REF(AAA,6)+REF(AAA,8))/36;
TJ1:=VOL=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>VAR41;
立桩量:=FILTER(TJ1,5);
TJ2:=IF(BARSLAST(立桩量)=1 AND CLOSE>REF(HIGH,1),1,IF(BARSLAST(立桩量)=2 AND CLOSE>REF(HIGH,2),1,IF(BARSLAST(立桩量)=3 AND CLOSE>REF(HIGH,3),1,0)));
突破:=TJ2=1;
TJ3:=IF(BARSLAST(立桩量)=1 AND CLOSE>REF(LOW,1),1,IF(BARSLAST(立桩量)=2 AND CLOSE>REF(LOW,2),1,IF(BARSLAST(立桩量)=3 AND CLOSE>REF(LOW,3),1,0)));
三天法则:=TJ3=1;
成立:=三天法则 AND 突破;
条件成立:=FILTER(成立,3);
DRAWTEXT(条件成立,L*0.99,'立桩量'),COLORYELLOW;[/lycode][lycode=tdx2,true]D赋值:72
输出压力: 多空均线+3*多空均线的10日估算标准差,线宽为0
输出支撑: 多空均线-3*多空均线的10日估算标准差,线宽为0
VARF赋值:(2*收盘价+最高价+最低价)/4
VA4赋值:34日内最低价的最低值
VA5赋值:34日内最高价的最高值
VA6赋值:(VARF-VA4)/(VA5-VA4)*100的6日指数移动平均
VA7赋值:0.667*1日前的VA6+0.333*VA6的4日指数移动平均
当满足条件如果统计8日中满足收盘价<1日前的收盘价的天数/8>0.3ANDCOUNT(VA6>VA7,3)ANDREF(最低价,1)=120日内最低价的最低值ANDCLOSE>开盘价,返回1,否则返回0时,在最低价*0.94位置书写文字,画黄色
VAR27赋值:1日前的收盘价
VAR28赋值:收盘价-VAR27和0的较大值的5.5日[1日权重]移动平均/收盘价-VAR27的绝对值的6日[1日权重]移动平均*100
当满足条件(如果76上穿VAR28,返回1,否则返回0)ORCROSS(70,RSI)时,在最高价*1.01位置画2号图标
当满足条件(如果VAR28上穿21,返回1,否则返回0)时,在最低价*0.97位置画1号图标
当满足条件(如果76上穿VAR28,返回1,否则返回0)ORCROSS(84,RSI)时,在最高价*1.03位置书写文字 ,画黄色
输出股价:收盘价的3日简单移动平均,画绿色,线宽为2
B赋值:股价<1日前的股价
输出短线:如果B-1,返回股价,否则返回无效数画洋红色,线宽为2
VAR4A赋值:收盘价的3日指数移动平均
当满足条件统计5日中满足1日前的VAR4A<2日前的VAR4A的天数=5ANDVAR4A>1日前的VAR4A时,在最低价*0.98位置画4号图标
当满足条件统计5日中满足1日前的VAR4A<2日前的VAR4A的天数=5ANDVAR4A>1日前的VAR4A时,在最低价*0.96位置书写文字
输出弱: 如果收盘价的13日简单移动平均>最低价的13日[2日权重]移动平均*1.01,返回最低价的13日[2日权重]移动平均*1.01,否则返回最低价的13日[2日权重]移动平均*1.01,画白色,线宽为1
输出强:如果最低价的13日[2日权重]移动平均*1.01>=1日前的最低价的13日[2日权重]移动平均*1.01,返回最低价的13日[2日权重]移动平均*1.01,否则返回无效数,画红色,线宽为1
VAR32赋值:100-3*(收盘价-D日内最低价的最低值)/(D日内最高价的最高值-D日内最低价的最低值)*100的20日[1日权重]移动平均+2*(收盘价-D日内最低价的最低值)/(D日内最高价的最高值-D日内最低价的最低值)*100的20日[1日权重]移动平均的15日[1日权重]移动平均
VAR33赋值:100-3*(开盘价-D日内最低价的最低值)/(D日内最高价的最高值-D日内最低价的最低值)*100的20日[1日权重]移动平均+2*(开盘价-D日内最低价的最低值)/(D日内最高价的最高值-D日内最低价的最低值)*100的20日[1日权重]移动平均的15日[1日权重]移动平均
VAR2F赋值:VAR32<1日前的VAR33 AND 成交量(手)>1日前的成交量(手) AND 收盘价>1日前的收盘价
当满足条件VAR2FANDCOUNT(VAR2F,30)=1时,在最低价*0.99位置书写文字,画洋红色
输出顶部:19日内最高价的最高值,线宽为1,画绿色
输出底部:19日内最低价的最低值,线宽为1,COLOR0099FF
EMA7赋值:收盘价的7日指数移动平均
EMA13赋值:收盘价的13日指数移动平均
EMA34赋值:收盘价的34日指数移动平均
EMA55赋值:收盘价的55日指数移动平均
EMA120赋值:收盘价的120日指数移动平均
CR1赋值:(收盘价-1日前的收盘价)/1日前的收盘价*100>0.5
CR2赋值:成交量(手)>成交量(手)的5日简单移动平均*0.6
CR3赋值:统计3日中满足EMA13上穿EMA55的天数=1
CR4赋值:EMA34-EMA55的绝对值/EMA55<0.03
CR5赋值:EMA55<=EMA120 AND EMA55>=1日前的EMA55
CR6赋值:CR1ANDCR2ANDCR3ANDCR4ANDCR5的2日过滤
当满足条件EMA7上穿EMA13时,在最高价*1.01位置书写文字,COLORF00FF0
当满足条件EMA7上穿EMA34时,在最高价*1.02位置书写文字
当满足条件EMA13上穿EMA34时,在最高价*1.03位置书写文字,COLORF00FF0
当满足条件CR6时,在最高价*1.01位置书写文字,COLORF00FF0
SAT赋值:如果(成交额(元)/收盘价)/(20日内成交额(元)的最高值/20日内收盘价的最高值)*100>100,返回100,否则返回(成交额(元)/收盘价)/(20日内成交额(元)的最高值/20日内收盘价的最高值)*100
AA10赋值:收盘价的8日简单移动平均,COLOR0000FF
AA12赋值:收盘价的12日简单移动平均,COLOR0000FF
BB10赋值:(((AA10-1日前的AA10)的反正切 * 3.1416) * 10)
BB12赋值:(((AA12-1日前的AA12)的反正切 * 3.1416) * 10)
MA13赋值:收盘价的13日简单移动平均
X1赋值:(收盘价+最低价+最高价)/3
BB13赋值:X1的13日指数移动平均-1日前的X1的13日指数移动平均的反正切*3.1416*10
EMA8赋值:收盘价的8日指数移动平均
当满足条件BB13>1ANDEMA(X1,13)>1日前的X1的8日指数移动平均的10日过滤时,在EMA8位置书写文字,画白色
LC赋值:1日前的收盘价
RSI赋值:(((收盘价-LC)和0的较大值的3日[1日权重]移动平均 / (收盘价-LC)的绝对值的3日[1日权重]移动平均) * 100)
V1赋值:收盘价的5日指数移动平均
V2赋值:收盘价的90日指数移动平均*1.01的10日指数移动平均
当满足条件V1上穿V2时,在V1+0.05位置书写文字,COLOR00FF00
VAR2AA赋值:收盘价的2日简单移动平均
VAR3AA赋值:如果(收盘价>1日前的收盘价),返回88,否则返回0
VAR4AA赋值:如果((收盘价)/(1日前的收盘价)>1.05)AND((最高价)/(收盘价)<1.01)AND(VAR3AA>0),返回91,否则返回0
当满足条件(VAR4AA>90)的45日过滤AND(最近1日VAR2AA连涨)时,在(最低价)*(0.97)位置书写文字,画红色
AAC赋值:收盘价/1日前的收盘价>=1.09
当满足条件AAC时,在最低价*0.97位置书写文字, 画黄色
当满足条件AAC时,在开盘价和收盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,画黄色
当满足条件AAC时,在最低价和最高价位置之间画柱状线,宽度为0,0不为0则画空心柱.,画黄色
平衡赋值:(收盘价+最低价)/2的3日[1日权重]移动平均的3日指数移动平均的5日[1日权重]移动平均
限制赋值:(((最高价+收盘价)/2+最低价+(收盘价+最低价)/2)/3-89日内((最高价+收盘价)/2+最低价+(收盘价+最低价)/2)/3的最低值的2日指数移动平均)/(21日内((最高价+收盘价)/2+最低价+(收盘价+最低价)/2)/3的最高值的2日指数移动平均-?日内((最高价+的最低值的?日指数移动平均的LOSE)/2+最低价+(收盘价+最低价)/2)/3,89),2))日指数移动平均*100
当满足条件平衡>1日前的平衡ANDHHV((最高价+收盘价)/2的13日简单移动平均,10)<1日前的10日内(最高价+收盘价)/2的13日简单移动平均的最高值AND((收盘价+最低价)/2)>1日前的(收盘价+最低价)/2的5日过滤AND限制<88时,在最低价*0.95位置书写文字,,COLORFFFF33
YC_买进赋值:((收盘价-1日前的收盘价的6日简单移动平均)/6+收盘价的6日简单移动平均)*1.004
买进条件赋值:收盘价上穿YC_买进 AND YC_买进>1日前的YC_买进,线宽为0
YC_加仓赋值:((收盘价-1日前的收盘价的18日简单移动平均)/18+收盘价的18日简单移动平均)*1.004
加仓条件赋值:收盘价上穿YC_加仓 AND YC_加仓>1日前的YC_加仓,线宽为0
当满足条件买进条件AND加仓条件时,在最低价*0.98位置书写文字
AAA赋值:(3*收盘价+最高价+最低价+开盘价)/6
VAR41赋值:(8*AAA+7*1日前的AAA+6*2日前的AAA+5*3日前的AAA+4*4日前的AAA+3*5日前的AAA+2*6日前的AAA+8日前的AAA)/36
TJ1赋值:成交量(手)=10日内成交量(手)的最高值 AND 成交量(手)>2*1日前的成交量(手) AND 收盘价>VAR41
立桩量赋值:TJ1的5日过滤
TJ2赋值:如果上次立桩量距今天数=1ANDCLOSE>1日前的最高价,返回1,否则返回如果上次立桩量距今天数=2ANDCLOSE>2日前的最高价,返回1,否则返回如果上次立桩量距今天数=3ANDCLOSE>3日前的最高价,返回1,否则返回0
突破赋值:TJ2=1
TJ3赋值:如果上次立桩量距今天数=1ANDCLOSE>1日前的最低价,返回1,否则返回如果上次立桩量距今天数=2ANDCLOSE>2日前的最低价,返回1,否则返回如果上次立桩量距今天数=3ANDCLOSE>3日前的最低价,返回1,否则返回0
三天法则赋值:TJ3=1
成立赋值:三天法则 AND 突破
条件成立赋值:成立的3日过滤
当满足条件条件成立时,在最低价*0.99位置书写文字,画黄色[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1UrUt7GlqzL7mY2z2EHE7ew

看了该指标的人还看了:
挖坑种树指标    KDJ全景指标
五里操盘1号指标    好当家指标

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表