请选择 进入手机版|继续访问电脑版

买卖宝指标 通达信 主图 无未来函数 买卖点 抄底逃顶 趋势 操盘控盘

[复制链接]

admin  管理员

发表于 2018-4-14 09:00:14 | 查看全部

指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 无未来函数 买卖点 抄底逃顶 趋势 操盘控盘 
买卖宝指标 通达信 主图 无未来函数 买卖点 抄底逃顶 趋势 操盘控盘 炒股叉第6319张

买卖宝指标 通达信 主图 无未来函数 买卖点 抄底逃顶 趋势 操盘控盘 炒股叉第6320张

[lywrap=通达信主图指标公式][lycode=tdx,true]{买卖宝}
动力线:MA(C,5),LINETHICK3,COLOR00CCFF;
牛熊线:MA(C,13),CIRCLEDOT,COLORYELLOW;
生命线:MA(C,34),CIRCLEDOT,COLORMAGENTA;
MA05:=MA(C,5);
MA10:=MA(C,10);
MA20:=MA(C,20);
MA30:=MA(C,30);
五日乖离率:=(C-MA05)/MA05*100;
BB05:=ATAN((MA05/REF(MA05,1)-1)*100)*180/3.1416;
速度5:=SMA(EMA((MA05-REF(MA05,1))/REF(MA05,1),3)*100,3,1);
加速度5:=EMA((速度5-REF(速度5,1)),3),NODRAW;
IF(BB05>30 AND MA05>REF(MA05,1), MA05,DRAWNULL),LINETHICK3,COLORRED;
BB10:=ATAN((MA10/REF(MA10,1)-1)*100)*180/3.1416;
IF(BB05<0 AND MA05<REF(MA05,1), MA05,DRAWNULL),LINETHICK3,COLORGREEN;
三拾日乖离率:=(C-MA30)/MA30*100,NODRAW;
VAR1:=(MA20-MA30)>REF((MA20-MA30),1) AND MA20>REF(MA20,1) AND MA30>REF(MA30,1);
VAR2:=(MA30-MA20)<REF((MA30-MA20),1) AND MA20<REF(MA20,1) AND MA30<REF(MA30,1);
BB30:=ATAN((MA30/REF(MA30,1)-1)*100)*180/3.1416;
强势狙击:=FILTER(BB30>30 AND BB10>45 AND CROSS(BB05,60),10);
加仓:=FILTER(COUNT(CROSS(BB05,30),5)>=1 AND MA05>REF(MA05,1) AND 三拾日乖离率>REF(三拾日乖离率,1) AND MA10>REF(MA10,1)
AND 加速度5>REF(加速度5,1) AND 速度5>REF(速度5,1) ,10) ;
清仓:=FILTER(COUNT(CROSS(30,BB05),5)>=1 AND (C>MA30 OR O>MA30) AND MA05<REF(MA05,1) AND 三拾日乖离率<REF(三拾日乖离率,1) AND MA10<REF(MA10,1),10);
DRAWTEXT(加仓 ,LOW*0.98,'◆加二'),COLORYELLOW;
JC:=CROSS(0,五日乖离率) AND 三拾日乖离率<REF(三拾日乖离率,1) AND MA10>REF(MA10,1) ;
减仓:=FILTER(JC,10);
MR:=COUNT(CROSS(五日乖离率,0),3)>=1 AND 三拾日乖离率>REF(三拾日乖离率,1) AND MA05>REF(MA05,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)<MA30;
买入:=FILTER(MR,10);
DRAWTEXT(减仓,HIGH*1.02,'◆风险'),COLORCYAN;
DRAWTEXT(买入,LOW*0.96,'◆买二'),COLORYELLOW;
DRAWTEXT(清仓 ,HIGH*1.00,'◆清仓'),COLORGREEN;
VAR21:=MAX(ABS(HIGH-AMOUNT/VOL/100),ABS(AMOUNT/VOL/100-LOW));
VAR3:=ABS((OPEN+CLOSE)/2-AMOUNT/VOL/100);
MV:=(VAR21+VAR3)/AMOUNT*VOL*100*50;
压力:MA(REF(HHV(C,30),1),2),COLOR9DFFFF;
支撑:MA(REF(LLV(C,30),1),2),COLORABFF46;
{彩色K线}
TYX3:=MA(REF(HHV((C+L+O+H)/4,30),1),3);
TYX4:=MA((C+L+O+H)/4,13);
TYX5:=EMA((C+L+O+H)/4,21);
{空心红}
STICKLINE(C<TYX5 AND C>O,H,L,0,0),COLORRED;
STICKLINE(C<TYX5 AND C>O,C,O,3,1),COLORRED;
{深绿}
STICKLINE(C<TYX5 AND C<O,H,L,0,0),COLOR007700;
STICKLINE(C<TYX5 AND C<O,C,O,3,0),COLOR005500;
STICKLINE(C<TYX5 AND C<O,C,O,2,0),COLOR006600;
STICKLINE(C<TYX5 AND C<O,C,O,1,0),COLOR007700;
{蓝}
STICKLINE(C>TYX5 AND C<O,H,L,0,0),COLORFFDD44;
STICKLINE(C>TYX5 AND C<O,C,O,3,0 ),COLORFF7700;
STICKLINE(C>TYX5 AND C<O,C,O,2,0 ),COLORFFAA22;
STICKLINE(C>TYX5 AND C<O,C,O,1 ,0 ),COLORFFDD44;
{黄}
STICKLINE(C>TYX5 AND C>O,H,L,0,0 ),COLOR00EEFF;
STICKLINE(C>TYX5 AND C>O,C,O,3,0 ),COLOR00AAFF;
STICKLINE(C>TYX5 AND C>O,C,O,2,0 ),COLOR00CCFF;
STICKLINE(C>TYX5 AND C>O,C,O,1,0 ),COLOR00EEFF;
{粉红}
STICKLINE(C>TYX4 AND C>O,H,L,0,0),COLORFF66AA;
STICKLINE(C>TYX4 AND C>O,C,O,3,0 ),COLORFF11FF;
STICKLINE(C>TYX4 AND C>O,C,O,2,0 ),COLORFF44FF;
STICKLINE(C>TYX4 AND C>O,C,O,1,0 ),COLORFF66FF;
{亮灰}
STICKLINE(C>TYX4 AND C<O,H,L,0,0),COLOR999999;
STICKLINE(C>TYX4 AND C<O,C,O,3,0),COLOR555555;
STICKLINE(C>TYX4 AND C<O,C,O,2,0),COLOR777777;
STICKLINE(C>TYX4 AND C<O,C,O,1,0),COLOR999999;
{深红}
STICKLINE(C>TYX3 AND C>O,H,L,0,0),COLOR0000DD;
STICKLINE(C>TYX3 AND C>O,C,O,3,0),COLOR000099;
STICKLINE(C>TYX3 AND C>O,C,O,2,0),COLOR0000BB;
STICKLINE(C>TYX3 AND C>O,C,O,1,0),COLOR0000DD;
{涨跌停K线}
STICKLINE(HIGH=LOW AND CLOSE=OPEN AND (CLOSE/REF(CLOSE,1))>1.048,HIGH,LOW,3,0) ,COLORRED;
STICKLINE(HIGH=LOW AND CLOSE=OPEN AND (REF(CLOSE,1)/CLOSE)>1.048,HIGH,LOW,3,0) ,COLOR00FF00;
{突破}
STICKLINE(REF(COUNT(C<TYX3,5)=5,1) AND C>TYX3 AND C>O,C,O,1,0),COLOR00CCFF;
{买卖主图}
MA18:=MA(CLOSE,18);
MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
买:=LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2));
DRAWTEXT(FILTER(买=1,5),LOW,'★买一'),COLORRED;
加1:=MA18>=REF(MA18,3) AND CROSS(CLOSE,MA18);
DRAWTEXT(加1,LOW*0.99,'★加一'),COLORCC66FF;
卖一:=HHV(DX,2)=HHV(DX,7) AND COUNT(DX>50,2) AND CROSS(MA(DX,2),DX);
DRAWTEXT(FILTER(卖一=1,1),HIGH*1.01,'★卖一'),COLORGREEN;
{牛熊通吃}
AA1:=AMOUNT/V;
BB1:=L<AA1*0.9;
CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD1:=L<MA(C,5)*0.921;
EE1:=V<MA(V,5)*1.5;
FF1:=BB1 AND CC1 AND DD1 AND EE1;
DRAWTEXT(FF1,LOW*0.99,'老鼠仓'),COLOR4080FF;
{股海网WWW.GUHAI.COM.CN整理}
{预测明天}
XXS:=MA(LOW,5)*(1-5/100);
XXS1:=MA(HIGH,5)*(1+5/100);
均线:=C,COLORGREEN;
AAAA:=CLOSE/REF(CLOSE,3)<=0.85 AND CROSS(C,XXS) AND C>REF(C,1),LINETHICK0 ;
DRAWTEXT(AAAA,L*0.95,'下影买'),COLORRED;
BBAA:=CROSS(XXS1,C);
DRAWTEXT(CROSS(XXS1,C),H,'开盘逃'),COLORWHITE;
DDDD:=CROSS(C,XXS1);
DRAWTEXT(DDDD,H,'明日走'),COLORYELLOW;
{兄弟指标}
AAA:=MA(LOW,5)*(1-5/100);
BBB:=(HHV(AAA,5)+LLV(AAA,5))/2;
DRAWTEXT(CROSS(BBB,L) AND BBB>REF(BBB,1),L*0.98,'←兄弟回马枪'),COLORWHITE;
{天河指标}
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
DRAWTEXT(REF(CROSS(DEA,DIF),1) AND CROSS(DIF,DEA),L*0.97,'←天河回马抢'),COLORMAGENTA;
{见好就收}
VSR2:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;
VSR3:=SMA(VSR2,4,1);
VSR4:=SMA(VSR3,2,1);
DRAWTEXT(VSR4>82 AND VSR3>89,HHV(C,30)*1.02,'收'),COLORGREEN;[/lycode][lycode=tdx2,true]输出动力线:收盘价的5日简单移动平均,线宽为3,COLOR00CCFF
输出牛熊线:收盘价的13日简单移动平均,CIRCLEDOT,画黄色
输出生命线:收盘价的34日简单移动平均,CIRCLEDOT,画洋红色
MA05赋值:收盘价的5日简单移动平均
MA10赋值:收盘价的10日简单移动平均
MA20赋值:收盘价的20日简单移动平均
MA30赋值:收盘价的30日简单移动平均
五日乖离率赋值:(收盘价-MA05)/MA05*100
BB05赋值:(MA05/1日前的MA05-1)*100的反正切*180/3.1416
速度5赋值:(MA05-1日前的MA05)/1日前的MA05的3日指数移动平均*100的3日[1日权重]移动平均
加速度5赋值:(速度5-1日前的速度5)的3日指数移动平均,NODRAW
如果BB05>30ANDMA05>1日前的MA05,返回MA05,否则返回无效数,线宽为3,画红色
BB10赋值:(MA10/1日前的MA10-1)*100的反正切*180/3.1416
如果BB05<0ANDMA05<1日前的MA05,返回MA05,否则返回无效数,线宽为3,画绿色
三拾日乖离率赋值:(收盘价-MA30)/MA30*100,NODRAW
VAR1赋值:(MA20-MA30)>1日前的(MA20-MA30) AND MA20>1日前的MA20 AND MA30>1日前的MA30
VAR2赋值:(MA30-MA20)<1日前的(MA30-MA20) AND MA20<1日前的MA20 AND MA30<1日前的MA30
BB30赋值:(MA30/1日前的MA30-1)*100的反正切*180/3.1416
强势狙击赋值:BB30>30ANDBB10>45ANDCROSS(BB05,60)的10日过滤
加仓赋值:统计5日中满足BB05上穿30的天数>=1ANDMA05>1日前的MA05AND三拾日乖离率>1日前的三拾日乖离率ANDMA10>1日前的MA10AND加速度5>1日前的加速度5AND速度5>1日前的速度5的10日过滤
清仓赋值:统计5日中满足30上穿BB05的天数>=1AND(收盘价>MA30ORO>MA30)ANDMA05<1日前的MA05AND三拾日乖离率<1日前的三拾日乖离率ANDMA10<1日前的MA10的10日过滤
当满足条件加仓时,在最低价*0.98位置书写文字,画黄色
JC赋值:0上穿五日乖离率 AND 三拾日乖离率<1日前的三拾日乖离率 AND MA10>1日前的MA10
减仓赋值:JC的10日过滤
MR赋值:统计3日中满足五日乖离率上穿0的天数>=1 AND 三拾日乖离率>1日前的三拾日乖离率 AND MA05>1日前的MA05 AND (收盘价/1日前的收盘价-1)*100>5 AND 1日前的收盘价<MA30
买入赋值:MR的10日过滤
当满足条件减仓时,在最高价*1.02位置书写文字,画青色
当满足条件买入时,在最低价*0.96位置书写文字,画黄色
当满足条件清仓时,在最高价*1.00位置书写文字,画绿色
VAR21赋值:最高价-成交额(元)/成交量(手)/100的绝对值和成交额(元)/成交量(手)/100-最低价的绝对值的较大值
VAR3赋值:(开盘价+收盘价)/2-成交额(元)/成交量(手)/100的绝对值
MV赋值:(VAR21+VAR3)/成交额(元)*成交量(手)*100*50
输出压力:1日前的30日内收盘价的最高值的2日简单移动平均,COLOR9DFFFF
输出支撑:1日前的30日内收盘价的最低值的2日简单移动平均,COLORABFF46
TYX3赋值:1日前的30日内(收盘价+最低价+开盘价+最高价)/4的最高值的3日简单移动平均
TYX4赋值:(收盘价+最低价+开盘价+最高价)/4的13日简单移动平均
TYX5赋值:(收盘价+最低价+开盘价+最高价)/4的21日指数移动平均
当满足条件收盘价<TYX5ANDC>开盘价时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,画红色
当满足条件收盘价<TYX5ANDC>开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为3,1不为0则画空心柱.,画红色
当满足条件收盘价<TYX5ANDC<开盘价时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR007700
当满足条件收盘价<TYX5ANDC<开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR005500
当满足条件收盘价<TYX5ANDC<开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR006600
当满足条件收盘价<TYX5ANDC<开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR007700
当满足条件收盘价>TYX5ANDC<开盘价时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLORFFDD44
当满足条件收盘价>TYX5ANDC<开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLORFF7700
当满足条件收盘价>TYX5ANDC<开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLORFFAA22
当满足条件收盘价>TYX5ANDC<开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLORFFDD44
当满足条件收盘价>TYX5ANDC>开盘价时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR00EEFF
当满足条件收盘价>TYX5ANDC>开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR00AAFF
当满足条件收盘价>TYX5ANDC>开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR00CCFF
当满足条件收盘价>TYX5ANDC>开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR00EEFF
当满足条件收盘价>TYX4ANDC>开盘价时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLORFF66AA
当满足条件收盘价>TYX4ANDC>开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLORFF11FF
当满足条件收盘价>TYX4ANDC>开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLORFF44FF
当满足条件收盘价>TYX4ANDC>开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLORFF66FF
当满足条件收盘价>TYX4ANDC<开盘价时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR999999
当满足条件收盘价>TYX4ANDC<开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR555555
当满足条件收盘价>TYX4ANDC<开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR777777
当满足条件收盘价>TYX4ANDC<开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR999999
当满足条件收盘价>TYX3ANDC>开盘价时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR0000DD
当满足条件收盘价>TYX3ANDC>开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR000099
当满足条件收盘价>TYX3ANDC>开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR0000BB
当满足条件收盘价>TYX3ANDC>开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR0000DD
当满足条件最高价=LOWANDCLOSE=OPENAND(收盘价/1日前的收盘价)>1.048时,在最高价和最低价位置之间画柱状线,宽度为3,0不为0则画空心柱. ,画红色
当满足条件最高价=LOWANDCLOSE=OPENAND(1日前的收盘价/收盘价)>1.048时,在最高价和最低价位置之间画柱状线,宽度为3,0不为0则画空心柱. ,COLOR00FF00
当满足条件1日前的统计5日中满足收盘价<TYX3的天数=5ANDC>TYX3ANDC>开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR00CCFF
MA18赋值:收盘价的18日简单移动平均
MTM赋值:收盘价-1日前的收盘价
DX赋值:100*MTM的6日指数移动平均的6日指数移动平均/MTM的绝对值的6日指数移动平均的6日指数移动平均
买赋值:2日内DX的最低值=7日内DX的最低值 AND 统计2日中满足DX<0的天数 AND DX上穿DX的2日简单移动平均
当满足条件买=1的5日过滤时,在最低价位置书写文字,画红色
加1赋值:MA18>=3日前的MA18 AND 收盘价上穿MA18
当满足条件加1时,在最低价*0.99位置书写文字,COLORCC66FF
卖一赋值:2日内DX的最高值=7日内DX的最高值 AND 统计2日中满足DX>50的天数 AND DX的2日简单移动平均上穿DX
当满足条件卖一=1的1日过滤时,在最高价*1.01位置书写文字,画绿色
AA1赋值:成交额(元)/成交量(手)
BB1赋值:最低价<AA1*0.9
CC1赋值:(收盘价-1日前的收盘价)/1日前的收盘价*100>1.2
DD1赋值:最低价<收盘价的5日简单移动平均*0.921
EE1赋值:成交量(手)<成交量(手)的5日简单移动平均*1.5
FF1赋值:BB1 AND CC1 AND DD1 AND EE1
当满足条件FF1时,在最低价*0.99位置书写文字,COLOR4080FF
XXS赋值:最低价的5日简单移动平均*(1-5/100)
XXS1赋值:最高价的5日简单移动平均*(1+5/100)
均线赋值:收盘价,画绿色
AAAA赋值:收盘价/3日前的收盘价<=0.85 AND 收盘价上穿XXS AND 收盘价>1日前的收盘价,线宽为0
当满足条件AAAA时,在最低价*0.95位置书写文字,画红色
BBAA赋值:XXS1上穿收盘价
当满足条件XXS1上穿收盘价时,在最高价位置书写文字,画白色
DDDD赋值:收盘价上穿XXS1
当满足条件DDDD时,在最高价位置书写文字,画黄色
AAA赋值:最低价的5日简单移动平均*(1-5/100)
BBB赋值:(5日内AAA的最高值+5日内AAA的最低值)/2
当满足条件BBB上穿最低价ANDBBB>1日前的BBB时,在最低价*0.98位置书写文字,画白色
DIF赋值:收盘价的12日指数移动平均-收盘价的26日指数移动平均
DEA赋值:DIF的9日指数移动平均
当满足条件1日前的DEA上穿DIFANDCROSS(DIF,DEA)时,在最低价*0.97位置书写文字,画洋红色
VSR2赋值:(收盘价-20日内最低价的最低值)/(20日内最高价的最高值-20日内最低价的最低值)*100
VSR3赋值:VSR2的4日[1日权重]移动平均
VSR4赋值:VSR3的2日[1日权重]移动平均
当满足条件VSR4>82ANDVSR3>89时,在30日内收盘价的最高值*1.02位置书写文字,画绿色[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1g3BvWtmLYvOeRB7k2NTtcA

看了该指标的人还看了:
趋线支撑与压力指标    百万导弹指标
买点雷达指标    波段抄底逃顶指标 成功率93.95%

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表