请选择 进入手机版|继续访问电脑版

完美买卖指标, 通达信 主图 无未来函数 买卖点 抄底逃顶 操盘控盘

[复制链接]

admin  管理员

发表于 2018-4-13 09:00:24 | 查看全部

指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 无未来函数 买卖点 抄底逃顶 操盘控盘 
完美买卖指标, 通达信 主图 无未来函数 买卖点 抄底逃顶 操盘控盘 炒股叉第6315张

完美买卖指标, 通达信 主图 无未来函数 买卖点 抄底逃顶 操盘控盘 炒股叉第6316张

[lywrap=通达信主图指标公式][lycode=tdx,true]{
P1 20 32 28
P2 32 36 32
P3 35 38 35
N 0 20 3
M 0 100 20
}
P1:=28;P2:=32;P3:=35;N:=3;M:=20;
VAR6Q:=REF(CLOSE,1);
VAR7Q:=SMA(MAX(CLOSE-VAR6Q,0),6,1)/SMA(ABS(CLOSE-VAR6Q),6,1)*100;
DRAWTEXT(CROSS(84,VAR7Q),H*1.03,'逃顶'),COLORYELLOW ;
VAR3P:=IF(CLOSE/REF(CLOSE,1)>1.050 AND HIGH/CLOSE<1.010 AND IF(CLOSE>REF(CLOSE,1),88,0)>0, 91, 0);
DRAWTEXT(VAR3P>90,LOW*0.92,'追涨'),COLORFF00FF;
VAR51:=EMA(AMOUNT/VOL/100,3);
VAR52:=EMA(VAR51,88);
VAR53:=EMA(VAR51,88)*0.85;
VAR54:=VAR53*0.87;
VAR55:=LOW<VAR54 AND CLOSE>REF(CLOSE,1)*1.02;
DRAWTEXT(FILTER(VAR55,6),LOW+0.1,'坚决买进'),  COLORYELLOW;
AA:=CROSS(MA(C,5),MA(C,20)) AND  CROSS(MA(C,5),MA(C,30)) AND CROSS(MA(C,5),MA(C,60));
BB:=MA(C,60)>MA(C,10) AND CROSS(MA(C,10),MA(C,30)) AND MA(C,30)>MA(C,20) AND ABS(MA(C,60)-MA(C,20))/MA(C,20)<0.05;
CC:=MA(C,30)>MA(C,5) AND CROSS(MA(C,5),MA(C,20)) AND MA(C,20)>MA(C,10), COLORYELLOW;
DD:=ABS((MA(C,5)-MA(C,10))+(MA(C,10)-MA(C,20))+(MA(C,20)-MA(C,30)))<0.02 AND MA(C,5)>REF(MA(C,5),1) AND MA(C,10)>REF(MA(C,10),1);
EE:=MA(C,20)>MA(C,5) AND CROSS(MA(C,5),MA(C,10)) AND MA(C,10)>MA(C,60) AND ABS(MA(C,20)-MA(C,60))/MA(C,60)<0.05;
FF:=AA OR BB OR CC OR DD OR EE ;
DRAWTEXT(FF,L*0.99,'庄现'),COLORYELLOW;
STICKLINE(FF,H,L,0.01,0),COLORFF00FF;
MA5:MA(CLOSE,5),COLORWHITE,LINETHICK2;
MA14:MA(CLOSE,14),COLORYELLOW,LINETHICK2;
MA21:MA(CLOSE,21),COLORMAGENTA,LINETHICK2;
MA34:MA(CLOSE,34),COLORRED,LINETHICK2;
MA55:MA(CLOSE,55),COLORGREEN,LINETHICK2;
MA89:MA(CLOSE,89),COLORYELLOW,LINETHICK2;
MA144:MA(CLOSE,144),COLORBROWN,LINETHICK2;
MA233:MA(CLOSE,233),COLORBLUE,LINETHICK2;
RSV:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
X:=LLV(J,2)=LLV(J,8);
Y:=IF(CROSS(J,REF(J+0.01,1)) AND X AND J<20,30,0);
主力:=EMA( (CLOSE-MA(CLOSE,3))/MA(CLOSE,3),2);
散户:=EMA( (CLOSE-MA(CLOSE,20))/MA(CLOSE,20),7);
VAR2:=LLV(LOW,10);
VAR3:=HHV(HIGH,25);
动能趋势线:=100*EMA((CLOSE-VAR2)/(VAR3-VAR2),4);
DRAWTEXT(CROSS(动能趋势线,70),HIGH*1.02,'险'),COLORGREEN;
DRAWTEXT(CROSS(动能趋势线,80),HIGH*1.02,'减'),COLOR00FF00;
DRAWTEXT(CROSS(动能趋势线,87.5),HIGH*1.02,'出局'),COLORWHITE;
DRAWTEXT(CROSS(J,REF(J+0.01,1)) AND X AND J<20,LOW,'短进'),COLORFF00FF;
DRAWTEXT(CROSS(主力,散户) AND 主力<0 AND 散户<0,LOW,'见底'),COLORRED;
DRAWICON(CROSS(主力,散户) AND 主力<0 AND 散户<0,LOW,1);
{黑马股}
AA1:=AMOUNT/V;
BB1:=L<AA1*0.9;
CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD1:=L<MA(C,5)*0.921;
EE1:=V<MA(V,5)*1.5;
FF1:=BB1 AND CC1 AND DD1 AND EE1;
DRAWTEXT(FF1,(LOW* 0.97),'庄影'),COLOR4080FF;
{涨跌停显示}
涨停:=IF((C-REF(C,1))*100/REF(C,1)>=(10-0.01*100/REF(O,1)),1,0);
STICKLINE(涨停,O,C,3,0),COLORRED;
ZDF:=(C-REF(C,1))/REF(C,1)*100;
STICKLINE(ZDF<-9.9,O,C,3,0),COLORGREEN;
{黑马}
A1A:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*1,5,1)-2*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*1,5,1),COLOR330066;
A5A:=(HHV(H,60)-C)/(HHV(H,60)-LLV(L,60))*1;
DRAWTEXT(CROSS(A1A,EMA(A1A,5))AND EMA(A1A,5)<A5A,L*0.98,'黑马'),COLORYELLOW;[/lycode][lycode=tdx2,true]P1赋值:28
P2赋值:32
P3赋值:35
N赋值:3
M赋值:20
VAR6Q赋值:1日前的收盘价
VAR7Q赋值:收盘价-VAR6Q和0的较大值的6日[1日权重]移动平均/收盘价-VAR6Q的绝对值的6日[1日权重]移动平均*100
当满足条件84上穿VAR7Q时,在最高价*1.03位置书写文字,画黄色
VAR3P赋值:如果收盘价/1日前的收盘价>1.050ANDHIGH/收盘价<1.010ANDIF(收盘价>1日前的收盘价,88,0)>0,返回91,否则返回0
当满足条件VAR3P>90时,在最低价*0.92位置书写文字,COLORFF00FF
VAR51赋值:成交额(元)/成交量(手)/100的3日指数移动平均
VAR52赋值:VAR51的88日指数移动平均
VAR53赋值:VAR51的88日指数移动平均*0.85
VAR54赋值:VAR53*0.87
VAR55赋值:最低价<VAR54 AND 收盘价>1日前的收盘价*1.02
当满足条件VAR55的6日过滤时,在最低价+0.1位置书写文字,  画黄色
AA赋值:收盘价的5日简单移动平均上穿收盘价的20日简单移动平均 AND  收盘价的5日简单移动平均上穿收盘价的30日简单移动平均 AND 收盘价的5日简单移动平均上穿收盘价的60日简单移动平均
BB赋值:收盘价的60日简单移动平均>收盘价的10日简单移动平均 AND 收盘价的10日简单移动平均上穿收盘价的30日简单移动平均 AND 收盘价的30日简单移动平均>收盘价的20日简单移动平均 AND 收盘价的60日简单移动平均-收盘价的20日简单移动平均的绝对值/收盘价的20日简单移动平均<0.05
CC赋值:收盘价的30日简单移动平均>收盘价的5日简单移动平均 AND 收盘价的5日简单移动平均上穿收盘价的20日简单移动平均 AND 收盘价的20日简单移动平均>收盘价的10日简单移动平均, 画黄色
DD赋值:(收盘价的5日简单移动平均-收盘价的10日简单移动平均)+(收盘价的10日简单移动平均-收盘价的20日简单移动平均)+(收盘价的20日简单移动平均-收盘价的30日简单移动平均)的绝对值<0.02 AND 收盘价的5日简单移动平均>1日前的收盘价的5日简单移动平均 AND 收盘价的10日简单移动平均>1日前的收盘价的10日简单移动平均
EE赋值:收盘价的20日简单移动平均>收盘价的5日简单移动平均 AND 收盘价的5日简单移动平均上穿收盘价的10日简单移动平均 AND 收盘价的10日简单移动平均>收盘价的60日简单移动平均 AND 收盘价的20日简单移动平均-收盘价的60日简单移动平均的绝对值/收盘价的60日简单移动平均<0.05
FF赋值:AA OR BB OR CC OR DD OR EE
当满足条件FF时,在最低价*0.99位置书写文字,画黄色
当满足条件FF时,在最高价和最低价位置之间画柱状线,宽度为0.01,0不为0则画空心柱.,COLORFF00FF
输出MA5:收盘价的5日简单移动平均,画白色,线宽为2
输出MA14:收盘价的14日简单移动平均,画黄色,线宽为2
输出MA21:收盘价的21日简单移动平均,画洋红色,线宽为2
输出MA34:收盘价的34日简单移动平均,画红色,线宽为2
输出MA55:收盘价的55日简单移动平均,画绿色,线宽为2
输出MA89:收盘价的89日简单移动平均,画黄色,线宽为2
输出MA144:收盘价的144日简单移动平均,画棕色,线宽为2
输出MA233:收盘价的233日简单移动平均,画蓝色,线宽为2
RSV赋值:(收盘价-9日内最低价的最低值)/(9日内最高价的最高值-9日内最低价的最低值)*100
K赋值:RSV的3日[1日权重]移动平均
D赋值:K的3日[1日权重]移动平均
J赋值:3*K-2*D
X赋值:2日内J的最低值=8日内J的最低值
Y赋值:如果J上穿1日前的J+0.01ANDXANDJ<20,返回30,否则返回0
主力赋值:(收盘价-收盘价的3日简单移动平均)/收盘价的3日简单移动平均的2日指数移动平均
散户赋值:(收盘价-收盘价的20日简单移动平均)/收盘价的20日简单移动平均的7日指数移动平均
VAR2赋值:10日内最低价的最低值
VAR3赋值:25日内最高价的最高值
动能趋势线赋值:100*(收盘价-VAR2)/(VAR3-VAR2)的4日指数移动平均
当满足条件动能趋势线上穿70时,在最高价*1.02位置书写文字,画绿色
当满足条件动能趋势线上穿80时,在最高价*1.02位置书写文字,COLOR00FF00
当满足条件动能趋势线上穿87.5时,在最高价*1.02位置书写文字,画白色
当满足条件J上穿1日前的J+0.01ANDXANDJ<20时,在最低价位置书写文字,COLORFF00FF
当满足条件主力上穿散户AND主力<0AND散户<0时,在最低价位置书写文字,画红色
当满足条件主力上穿散户AND主力<0AND散户<0时,在最低价位置画1号图标
AA1赋值:成交额(元)/成交量(手)
BB1赋值:最低价<AA1*0.9
CC1赋值:(收盘价-1日前的收盘价)/1日前的收盘价*100>1.2
DD1赋值:最低价<收盘价的5日简单移动平均*0.921
EE1赋值:成交量(手)<成交量(手)的5日简单移动平均*1.5
FF1赋值:BB1 AND CC1 AND DD1 AND EE1
当满足条件FF1时,在(最低价*0.97)位置书写文字,COLOR4080FF
涨停赋值:如果(收盘价-1日前的收盘价)*100/1日前的收盘价>=(10-0.01*100/1日前的开盘价),返回1,否则返回0
当满足条件涨停时,在开盘价和收盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,画红色
ZDF赋值:(收盘价-1日前的收盘价)/1日前的收盘价*100
当满足条件ZDF<-9.9时,在开盘价和收盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,画绿色
A1A赋值:3*(收盘价-55日内最低价的最低值)/(55日内最高价的最高值-55日内最低价的最低值)*1的5日[1日权重]移动平均-2*(收盘价-55日内最低价的最低值)/(55日内最高价的最高值-55日内最低价的最低值)*1的5日[1日权重]移动平均,COLOR330066
A5A赋值:(60日内最高价的最高值-收盘价)/(60日内最高价的最高值-60日内最低价的最低值)*1
当满足条件A1A上穿A1A的5日指数移动平均ANDEMA(A1A,5)<A5A时,在最低价*0.98位置书写文字,画黄色[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/140z9yCDgcWVepRUzrGw_tw

看了该指标的人还看了:
狂龙出海指标    横盘启动买点指标
启动买点指标    宝岛精英指标

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表