请选择 进入手机版|继续访问电脑版

五星黄金波段指标 通达信 主图 波段 无未来函数 买卖点 趋势 操盘控盘

[复制链接]

admin  管理员

发表于 2018-4-13 09:00:24 | 查看全部

指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 波段 无未来函数 买卖点 趋势 操盘控盘 
五星黄金波段指标 通达信 主图 波段 无未来函数 买卖点 趋势 操盘控盘 炒股叉第6307张

五星黄金波段指标 通达信 主图 波段 无未来函数 买卖点 趋势 操盘控盘 炒股叉第6308张

[lywrap=通达信主图指标公式][lycode=tdx,true]DRAWGBK(1,RGB(0,0,0),RGB(0,0,0),0,'BJ1',0);
{======================================================}
范围高A:=REFDATE(HHV(H,120),DATE)*1.05;
范围低A:=REFDATE(LLV(L,120),DATE)*0.95;
MA5:=MA(C,5),COLORCYAN,LINETHICK2;
MA24:=MA(C,24),COLORGREEN,LINETHICK2;
MA72:=MA(C,72),COLORRED,LINETHICK2;
MA200:=IF((MA(C,200)<=范围高A AND MA(C,200)>=范围低A) OR C>=MA(C,200),MA(C,200),DRAWNULL),COLORBLUE,LINETHICK2;
{=======================仪表盘=========================}
主升浪:=ISLASTBAR AND MA5>MA24 AND MA24>MA72 AND MA72>IF(MA200=DRAWNULL,0,MA200);
主浪回调:=ISLASTBAR AND MA24>MA5 AND MA5>MA72 AND MA72>IF(MA200=DRAWNULL,0,MA200);
主浪深调:=ISLASTBAR AND MA24>MA72 AND MA72>MA5 AND MA5>IF(MA200=DRAWNULL,0,MA200);
初升浪:=ISLASTBAR AND IF(MA200=DRAWNULL,300,MA200)>MAX(MA24,MA72) AND MA5>MA24 AND MA24>MA72;
底部反弹:=ISLASTBAR AND IF(MA200=DRAWNULL,300,MA200)>MA72 AND MA72>MA24 AND MA5>MA24;
探底阶段:=ISLASTBAR AND IF(MA200=DRAWNULL,300,MA200)>MA72 AND MA72>MA24 AND MA24>MA5;
观望:=ISLASTBAR AND IF(MA200=DRAWNULL,MA24>MA72 AND C<MA72,MA72>MA200 AND C<MA200);
有牛:=ISLASTBAR AND IF(MA200=DRAWNULL,MA24<MA72 AND C>=MA72,MA72<MA200 AND C>=MA200);
放弃:=ISLASTBAR AND IF(MA200=DRAWNULL,MA24<MA72 AND C<MA72,MA72<MA200 AND C<MA200);
DRAWGBK(显示仪表盘1=1 AND 主升浪=0 AND 主浪回调=0 AND 主浪深调=0 AND 初升浪=0 AND 底部反弹=0 AND 探底阶段=0 AND 观望=0 AND 有牛=0 AND 放弃=0,0,0,0,'观望',0)COLOR00BF00;
DRAWGBK(显示仪表盘1=1 AND 主升浪,0,0,0,'主升浪',0)COLORFF00FF;
DRAWGBK(显示仪表盘1=1 AND 主浪回调,0,0,0,'主浪回调',0)COLORFF8080;
DRAWGBK(显示仪表盘1=1 AND 主浪深调,0,0,0,'主浪深调',0)COLOR009500;
DRAWGBK(显示仪表盘1=1 AND 初升浪,0,0,0,'初升浪',0)COLOR00FFFF;
DRAWGBK(显示仪表盘1=1 AND 底部反弹,0,0,0,'底部反弹',0)COLORFFFF00;
DRAWGBK(显示仪表盘1=1 AND 探底阶段,0,0,0,'探底阶段',0);
DRAWGBK(显示仪表盘1=1 AND 观望,0,0,0,'观望',0)COLORFFFF00;
DRAWGBK(显示仪表盘1=1 AND 有牛,0,0,0,'有牛',0)COLOR00FFFF;
DRAWGBK(显示仪表盘1=1 AND 放弃,0,0,0,'放弃',0)COLOR00BF00;
引差:=REF(C,1)-LOW,LINETHICK1,NODRAW;
引跌幅:IF((REF(C,1)-LOW)/REF(C,1)*100>0,(REF(C,1)-LOW)/REF(C,1)*100,0),LINETHICK1,NODRAW;
三日均跌:MA(引跌幅,3),COLORWHITE,NODRAW;

N:=120;
K:=BARSLAST(CURRBARSCOUNT=N);
GD:=CONST(IF(ISLASTBAR=1,HHV(H,K),0)),NODRAW;{高点}
DD:=CONST(IF(ISLASTBAR=1,LLV(L,K),0)),NODRAW;{低点}
KJ:=GD-DD;{高低点差值=分区高度}
GD4:=IF(CURRBARSCOUNT<=N/2,GD,DRAWNULL);
高区:IF(CURRBARSCOUNT<=N,GD,DRAWNULL),COLORRED,LINETHICK2,NODRAW;
低区:IF(CURRBARSCOUNT<=N,DD,DRAWNULL),COLOR00FF00,LINETHICK2,NODRAW;
平衡:=IF(CURRBARSCOUNT<=N,DD+KJ/2,DRAWNULL),COLOR00FFFF,NODRAW;
低:IF(CURRBARSCOUNT<=N/2,DD,DRAWNULL),COLORFFFF00;
高:IF(CURRBARSCOUNT<=N/2,GD,DRAWNULL),COLOR00FFFF;
支撑:IF(CURRBARSCOUNT<=N/2,DD+KJ*0.191,DRAWNULL),COLOR00FFFF;
强势: IF(CURRBARSCOUNT<=N/2,DD+KJ*0.382,DRAWNULL),COLORFF00FF;
突破:IF(CURRBARSCOUNT<=N/2,DD+KJ/2,DRAWNULL),COLOR0000FF;
警示:IF(CURRBARSCOUNT<=N/2,DD+KJ*0.618,DRAWNULL),COLOR00FFFF;
压力:IF(CURRBARSCOUNT<=N/2,DD+KJ*0.809,DRAWNULL),COLOR00FF00;
低涨:IF(CURRBARSCOUNT<=N/2,(C/LLV(LOW,K)-1)*100,DRAWNULL),COLOR0000FF,NODRAW;
天数:BARSLAST(L=DD),COLORCYAN,NODRAW;
顶点:IF(CURRBARSCOUNT<=N/2, CONST(IF(ISLASTBAR=1,HHV(H, BARSLAST(CURRBARSCOUNT=60)),1)),DRAWNULL),COLORRED,CROSSDOT,NODRAW;
低点:IF(CURRBARSCOUNT<=N/2, CONST(IF(ISLASTBAR=1,LLV(L, BARSLAST(CURRBARSCOUNT=60)),1)),DRAWNULL),COLORMAGENTA,CROSSDOT,NODRAW;
STICKLINE(CCI>=200 AND H>=顶点,O,C,2,0),COLORBLUE;
STICKLINE(CCI<=100 AND L<=低点,O,C,2,0),COLORYELLOW;

DRAWBAND(高区,RGB(0,0,0),平衡,RGB(0,0,0));
DRAWBAND(平衡,RGB(0,0,0),低区,RGB(0,0,0));
DRAWBAND(高,RGB(120,100,0),压力,RGB(0,0,0));
DRAWBAND(压力,RGB(258,58,0),警示,RGB(0,0,0));
DRAWBAND(警示,RGB(128,58,0),突破,RGB(0,0,0));
DRAWBAND(突破,RGB(68,0,0),强势,RGB(0,0,0));
DRAWBAND(强势,RGB(38,0,0),支撑,RGB(0,0,0));
DRAWBAND(支撑,RGB(38,38,38),低,RGB(0,0,0));


STICKLINE(CURRBARSCOUNT=N/2,GD,DD,0,0),COLOR408080,NODRAW;

STICKLINE(CURRBARSCOUNT<=N/2,支撑,支撑,2,0),COLOR1E1E1E;
STICKLINE(CURRBARSCOUNT<=N/2,强势,强势,2,0),COLOR1E1E1E;
STICKLINE(CURRBARSCOUNT<=N/2,突破,突破,2,0),COLOR1E1E1E;
STICKLINE(CURRBARSCOUNT<=N/2,警示,警示,2,0),COLOR1E1E1E;
STICKLINE(CURRBARSCOUNT<=N/2,压力,压力,2,0),COLOR1E1E1E;
DRAWTEXT(CURRBARSCOUNT=10,压力,'压力-0.809'),COLOR00FFFF,NODRAW;
DRAWTEXT(CURRBARSCOUNT=10,警示,'警示-0.618'),COLOR00FFFF,NODRAW;
DRAWTEXT(CURRBARSCOUNT=10,突破,'突破-0.500'),COLOR00FFFF,NODRAW;
DRAWTEXT(CURRBARSCOUNT=10,强势,'强势-0.382'),COLOR00FFFF,NODRAW;
DRAWTEXT(CURRBARSCOUNT=10,支撑,'支撑-0.191'),COLOR00FFFF,NODRAW;
DRAWTEXT(CURRBARSCOUNT=N/4+5,GD-KJ*0.09,'【风险区】--高抛避险'),COLORFFFFFF;
DRAWTEXT(CURRBARSCOUNT=N/4+5,GD-KJ*0.3,'【警示区】--逢高减仓'),COLORFFFFFF;
DRAWTEXT(CURRBARSCOUNT=N/4+5,GD-KJ*0.45,'【突破区】--主力拉升'),COLORFFFFFF;
DRAWTEXT(CURRBARSCOUNT=N/4+5,GD-KJ*0.55,'【拉升区】--强势畜锐'),COLORFFFFFF;
DRAWTEXT(CURRBARSCOUNT=N/4+5,DD+KJ/3,'【关注区】--逢低买入'),COLORFFFFFF;
DRAWTEXT(CURRBARSCOUNT=N/4+5,DD+KJ/10,'【低吸区】--大胆买入'),COLORFFFFFF;

第一防线:REFDATE(低,DATE),DOTLINE,COLORYELLOW,NODRAW;
第二防线:REFDATE(支撑,DATE),DOTLINE,COLORWHITE,NODRAW;
{今日保护价:(REF(C,2)+REF(C,1)+O)/3 ,COLORCC3299;}
DRAWKLINE(H,O,L,C);
AHC1:=CLOSE*VOL;
AHC22:=EMA((EXPMA(AHC1,27)/EXPMA(VOL,27)+EXPMA(AHC1,54)/EXPMA(VOL,54)+EXPMA(AHC1,108)/EXPMA(VOL,108)+EXPMA(AHC1,316)/EXPMA(VOL,316))/4,34);
上轨:=1.06*AHC22,COLOR40FF00,LINETHICK1;
下轨:=AHC22*0.94;
{STICKLINE(上轨>下轨,上轨,下轨,5,0),COLOR555555;}
ZT:=REF(C,1)*1.1-C<0.01 AND H=C;
启爆:=CROSS(C,上轨) OR CROSS(C,下轨) AND ZT;
DRAWTEXT(启爆,L,'启爆'),COLORCYAN;
STICKLINE(启爆,C,O,3,1),COLORWHITE;
STICKLINE(启爆,C,O,1,0),COLORGREEN;


STICKLINE(C>=O ,HIGH,LOW,0,1 ),COLORRED;
STICKLINE(C>=O ,OPEN,CLOSE,3.1,0 ),COLOR000033;
STICKLINE(C>=O,OPEN,CLOSE,2.7,0 ),COLOR000066;
STICKLINE(C>=O ,OPEN,CLOSE,2.1,0 ),COLOR000099;
STICKLINE(C>=O ,OPEN,CLOSE,1.5,0 ),COLOR0000CC;
STICKLINE(C>=O ,OPEN,CLOSE,0.9,0 ),COLOR0000FF;
STICKLINE(C>=O ,OPEN,CLOSE,0.3,0 ),COLORCC66FF;
STICKLINE(C<O ,HIGH,LOW,0,1 ),COLORCYAN;
STICKLINE(C<O ,OPEN,CLOSE,3.1,0 ),COLOR990000;
STICKLINE(CLOSE<O ,OPEN,CLOSE,2.7,0 ),COLORCC0000;
STICKLINE(CLOSE<O ,OPEN,CLOSE,2.1,0 ),COLORFF4400;
STICKLINE(CLOSE<O ,OPEN,CLOSE,1.5,0 ),COLORFF8800;
STICKLINE(CLOSE<O ,OPEN,CLOSE,0.9,0 ),COLORFFCC00;
STICKLINE(CLOSE<O ,OPEN,CLOSE,0.3,0 ),COLORCYAN;


CC:IF(CURRBARSCOUNT<18,CONST(REF(C,1)),DRAWNULL),COLOR000000,NODRAW;
止赢:1.05*CC,COLORMAGENTA,LINETHICK1;
DRAWTEXT(ISLASTBAR,止赢,'止赢'),LINETHICK1;
止损:0.97*CC,COLORYELLOW,LINETHICK1;
DRAWTEXT(ISLASTBAR,止损,'止损'),LINETHICK1;
DRAWNUMBER(ISLASTBAR  ,C,C),COLORWHITE;
AAA:=CONST(HHV(H,50));PL5:=HHV(H,45);
F:=100*(C-REF(C,1))/REF(C,1);
博尔:=IF(C<REF(O,1) AND F<0,1,0);
P1:=博尔;
量化:=IF(C<REF(O,2) AND F<0,1,0);
P2:=量化;
STICKLINE(P1=0 AND REF(P1,1)=1 AND P2=0 AND REF(P2,1)=1,OPEN,CLOSE,3,0),COLOR0055FF;
操作30日均线:EMA(C,30),COLORYELLOW,LINETHICK4;
红升:IF(操作30日均线>REF(操作30日均线,1),操作30日均线,DRAWNULL),COLORRED,LINETHICK4;
绿降:IF(操作30日均线<REF(操作30日均线,1),操作30日均线,DRAWNULL),COLOR009300,LINETHICK4;
趋势55日线:EMA(C,55),COLORYELLOW,LINETHICK1,NODRAW;
红升4:IF(趋势55日线>REF(趋势55日线,1),趋势55日线,DRAWNULL),COLOR0080FF,LINETHICK1;
绿降4:IF(趋势55日线<REF(趋势55日线,1),趋势55日线,DRAWNULL),COLORFFFF00,DOTLINE,LINETHICK1;

年线:EMA(C,250),COLORYELLOW,LINETHICK1,NODRAW;
年红升:IF(年线>REF(年线,1),年线,DRAWNULL),COLOR8000FF,LINETHICK1;
年绿降:IF(年线<REF(年线,1),年线,DRAWNULL),COLORFFFF00,DOTLINE,LINETHICK1;[/lycode][lycode=tdx2,true]填充背景
范围高A赋值:日期日120日内最高价的最高值*1.05
范围低A赋值:日期日120日内最低价的最低值*0.95
MA5赋值:收盘价的5日简单移动平均,画青色,线宽为2
MA24赋值:收盘价的24日简单移动平均,画绿色,线宽为2
MA72赋值:收盘价的72日简单移动平均,画红色,线宽为2
MA200赋值:如果(收盘价的200日简单移动平均<=范围高AANDMA(收盘价,200)>=范围低A)ORC>=收盘价的200日简单移动平均,返回收盘价的200日简单移动平均,否则返回无效数,画蓝色,线宽为2
主升浪赋值:是否最后一个周期 AND MA5>MA24 AND MA24>MA72 AND MA72>如果MA200=无效数,返回0,否则返回MA200
主浪回调赋值:是否最后一个周期 AND MA24>MA5 AND MA5>MA72 AND MA72>如果MA200=无效数,返回0,否则返回MA200
主浪深调赋值:是否最后一个周期 AND MA24>MA72 AND MA72>MA5 AND MA5>如果MA200=无效数,返回0,否则返回MA200
初升浪赋值:是否最后一个周期 AND 如果MA200=无效数,返回300,否则返回MA200>MA24和MA72的较大值 AND MA5>MA24 AND MA24>MA72
底部反弹赋值:是否最后一个周期 AND 如果MA200=无效数,返回300,否则返回MA200>MA72 AND MA72>MA24 AND MA5>MA24
探底阶段赋值:是否最后一个周期 AND 如果MA200=无效数,返回300,否则返回MA200>MA72 AND MA72>MA24 AND MA24>MA5
观望赋值:是否最后一个周期 AND 如果MA200=无效数,返回MA24>MA72ANDC<MA72,否则返回MA72>MA200ANDC<MA200
有牛赋值:是否最后一个周期 AND 如果MA200=无效数,返回MA24<MA72ANDC>=MA72,否则返回MA72<MA200ANDC>=MA200
放弃赋值:是否最后一个周期 AND 如果MA200=无效数,返回MA24<MA72ANDC<MA72,否则返回MA72<MA200ANDC<MA200
填充背景COLOR00BF00
填充背景COLORFF00FF
填充背景COLORFF8080
填充背景COLOR009500
填充背景COLOR00FFFF
填充背景COLORFFFF00
填充背景
填充背景COLORFFFF00
填充背景COLOR00FFFF
填充背景COLOR00BF00
引差赋值:1日前的收盘价-最低价,线宽为1,NODRAW
输出引跌幅:如果(1日前的收盘价-最低价)/1日前的收盘价*100>0,返回(1日前的收盘价-最低价)/1日前的收盘价*100,否则返回0,线宽为1,NODRAW
输出三日均跌:引跌幅的3日简单移动平均,画白色,NODRAW
N赋值:120
K赋值:上次到最后交易的周期=N距今天数
GD赋值:如果是否最后一个周期=1,返回K日内最高价的最高值,否则返回0的最后一日取值设为常数,NODRAW
DD赋值:如果是否最后一个周期=1,返回K日内最低价的最低值,否则返回0的最后一日取值设为常数,NODRAW
KJ赋值:GD-DD
GD4赋值:如果到最后交易的周期<=N/2,返回GD,否则返回无效数
输出高区:如果到最后交易的周期<=N,返回GD,否则返回无效数,画红色,线宽为2,NODRAW
输出低区:如果到最后交易的周期<=N,返回DD,否则返回无效数,COLOR00FF00,线宽为2,NODRAW
平衡赋值:如果到最后交易的周期<=N,返回DD+KJ/2,否则返回无效数,COLOR00FFFF,NODRAW
输出低:如果到最后交易的周期<=N/2,返回DD,否则返回无效数,COLORFFFF00
输出高:如果到最后交易的周期<=N/2,返回GD,否则返回无效数,COLOR00FFFF
输出支撑:如果到最后交易的周期<=N/2,返回DD+KJ*0.191,否则返回无效数,COLOR00FFFF
输出强势: 如果到最后交易的周期<=N/2,返回DD+KJ*0.382,否则返回无效数,COLORFF00FF
输出突破:如果到最后交易的周期<=N/2,返回DD+KJ/2,否则返回无效数,COLOR0000FF
输出警示:如果到最后交易的周期<=N/2,返回DD+KJ*0.618,否则返回无效数,COLOR00FFFF
输出压力:如果到最后交易的周期<=N/2,返回DD+KJ*0.809,否则返回无效数,COLOR00FF00
输出低涨:如果到最后交易的周期<=N/2,返回(收盘价/K日内最低价的最低值-1)*100,否则返回无效数,COLOR0000FF,NODRAW
输出天数:上次最低价=DD距今天数,画青色,NODRAW
输出顶点:如果到最后交易的周期<=N/2,返回如果是否最后一个周期=1,返回上次到最后交易的周期=60距今天数日内最高价的最高值,否则返回1的最后一日取值设为常数,否则返回无效数,画红色,CROSSDOT,NODRAW
输出低点:如果到最后交易的周期<=N/2,返回如果是否最后一个周期=1,返回上次到最后交易的周期=60距今天数日内最低价的最低值,否则返回1的最后一日取值设为常数,否则返回无效数,画洋红色,CROSSDOT,NODRAW
当满足条件CCI>=200ANDH>=顶点时,在开盘价和收盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,画蓝色
当满足条件CCI<=100ANDL<=低点时,在开盘价和收盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,画黄色
画带状线
画带状线
画带状线
画带状线
画带状线
画带状线
画带状线
画带状线
当满足条件到最后交易的周期=N/2时,在GD和DD位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR408080,NODRAW
当满足条件到最后交易的周期<=N/2时,在支撑和支撑位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR1E1E1E
当满足条件到最后交易的周期<=N/2时,在强势和强势位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR1E1E1E
当满足条件到最后交易的周期<=N/2时,在突破和突破位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR1E1E1E
当满足条件到最后交易的周期<=N/2时,在警示和警示位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR1E1E1E
当满足条件到最后交易的周期<=N/2时,在压力和压力位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR1E1E1E
当满足条件到最后交易的周期=10时,在压力位置书写文字,COLOR00FFFF,NODRAW
当满足条件到最后交易的周期=10时,在警示位置书写文字,COLOR00FFFF,NODRAW
当满足条件到最后交易的周期=10时,在突破位置书写文字,COLOR00FFFF,NODRAW
当满足条件到最后交易的周期=10时,在强势位置书写文字,COLOR00FFFF,NODRAW
当满足条件到最后交易的周期=10时,在支撑位置书写文字,COLOR00FFFF,NODRAW
当满足条件到最后交易的周期=N/4+5时,在GD-KJ*0.09位置书写文字,COLORFFFFFF
当满足条件到最后交易的周期=N/4+5时,在GD-KJ*0.3位置书写文字,COLORFFFFFF
当满足条件到最后交易的周期=N/4+5时,在GD-KJ*0.45位置书写文字,COLORFFFFFF
当满足条件到最后交易的周期=N/4+5时,在GD-KJ*0.55位置书写文字,COLORFFFFFF
当满足条件到最后交易的周期=N/4+5时,在DD+KJ/3位置书写文字,COLORFFFFFF
当满足条件到最后交易的周期=N/4+5时,在DD+KJ/10位置书写文字,COLORFFFFFF
输出第一防线:日期日低,DOTLINE,画黄色,NODRAW
输出第二防线:日期日支撑,DOTLINE,画白色,NODRAW
K线
AHC1赋值:收盘价*成交量(手)
AHC22赋值:(AHC1的27日指数移动平均/成交量(手)的27日指数移动平均+AHC1的54日指数移动平均/成交量(手)的54日指数移动平均+AHC1的108日指数移动平均/成交量(手)的108日指数移动平均+AHC1的316日指数移动平均/成交量(手)的316日指数移动平均)/4的34日指数移动平均
上轨赋值:1.06*AHC22,COLOR40FF00,线宽为1
下轨赋值:AHC22*0.94
ZT赋值:1日前的收盘价*1.1-收盘价<0.01 AND 最高价=收盘价
启爆赋值:收盘价上穿上轨 OR 收盘价上穿下轨 AND ZT
当满足条件启爆时,在最低价位置书写文字,画青色
当满足条件启爆时,在收盘价和开盘价位置之间画柱状线,宽度为3,1不为0则画空心柱.,画白色
当满足条件启爆时,在收盘价和开盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,画绿色
当满足条件收盘价>=开盘价时,在最高价和最低价位置之间画柱状线,宽度为0,1不为0则画空心柱.,画红色
当满足条件收盘价>=开盘价时,在开盘价和收盘价位置之间画柱状线,宽度为3.1,0不为0则画空心柱.,COLOR000033
当满足条件收盘价>=开盘价时,在开盘价和收盘价位置之间画柱状线,宽度为2.7,0不为0则画空心柱.,COLOR000066
当满足条件收盘价>=开盘价时,在开盘价和收盘价位置之间画柱状线,宽度为2.1,0不为0则画空心柱.,COLOR000099
当满足条件收盘价>=开盘价时,在开盘价和收盘价位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLOR0000CC
当满足条件收盘价>=开盘价时,在开盘价和收盘价位置之间画柱状线,宽度为0.9,0不为0则画空心柱.,COLOR0000FF
当满足条件收盘价>=开盘价时,在开盘价和收盘价位置之间画柱状线,宽度为0.3,0不为0则画空心柱.,COLORCC66FF
当满足条件收阴线时,在最高价和最低价位置之间画柱状线,宽度为0,1不为0则画空心柱.,画青色
当满足条件收阴线时,在开盘价和收盘价位置之间画柱状线,宽度为3.1,0不为0则画空心柱.,COLOR990000
当满足条件收阴线时,在开盘价和收盘价位置之间画柱状线,宽度为2.7,0不为0则画空心柱.,COLORCC0000
当满足条件收阴线时,在开盘价和收盘价位置之间画柱状线,宽度为2.1,0不为0则画空心柱.,COLORFF4400
当满足条件收阴线时,在开盘价和收盘价位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLORFF8800
当满足条件收阴线时,在开盘价和收盘价位置之间画柱状线,宽度为0.9,0不为0则画空心柱.,COLORFFCC00
当满足条件收阴线时,在开盘价和收盘价位置之间画柱状线,宽度为0.3,0不为0则画空心柱.,画青色
输出CC:如果到最后交易的周期<18,返回1日前的收盘价的最后一日取值设为常数,否则返回无效数,COLOR000000,NODRAW
输出止赢:1.05*CC,画洋红色,线宽为1
当满足条件是否最后一个周期时,在止赢位置书写文字,线宽为1
输出止损:0.97*CC,画黄色,线宽为1
当满足条件是否最后一个周期时,在止损位置书写文字,线宽为1
当满足条件是否最后一个周期时,在收盘价位置书写数字,画白色
AAA赋值:50日内最高价的最高值的最后一日取值设为常数
PL5赋值:45日内最高价的最高值
F赋值:100*(收盘价-1日前的收盘价)/1日前的收盘价
博尔赋值:如果收盘价<1日前的开盘价ANDF<0,返回1,否则返回0
P1赋值:博尔
量化赋值:如果收盘价<2日前的开盘价ANDF<0,返回1,否则返回0
P2赋值:量化
当满足条件P1=0ANDREF(P1,1)=1ANDP2=0ANDREF(P2,1)=1时,在开盘价和收盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR0055FF
输出操作30日均线:收盘价的30日指数移动平均,画黄色,线宽为4
输出红升:如果操作30日均线>1日前的操作30日均线,返回操作30日均线,否则返回无效数,画红色,线宽为4
输出绿降:如果操作30日均线<1日前的操作30日均线,返回操作30日均线,否则返回无效数,COLOR009300,线宽为4
输出趋势55日线:收盘价的55日指数移动平均,画黄色,线宽为1,NODRAW
输出红升4:如果趋势55日线>1日前的趋势55日线,返回趋势55日线,否则返回无效数,COLOR0080FF,线宽为1
输出绿降4:如果趋势55日线<1日前的趋势55日线,返回趋势55日线,否则返回无效数,COLORFFFF00,DOTLINE,线宽为1
输出年线:收盘价的250日指数移动平均,画黄色,线宽为1,NODRAW
输出年红升:如果年线>1日前的年线,返回年线,否则返回无效数,COLOR8000FF,线宽为1
输出年绿降:如果年线<1日前的年线,返回年线,否则返回无效数,COLORFFFF00,DOTLINE,线宽为1[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1uQNm0XU3aqzi_wkldQ6Hfg

看了该指标的人还看了:
八卦太极指标 成功率89%    底部机会指标
涨停板抄底指标    买了不输指标

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表