请选择 进入手机版|继续访问电脑版

资金潮指标 通达信 副图 资金流向 无未来函数 买卖点 操盘控盘

[复制链接]

admin  管理员

发表于 2018-4-13 09:00:24 | 查看全部

指标公式
软件: 通达信 
公式类型: 副图 
二级分类: 资金流向 无未来函数 买卖点 操盘控盘 
此指标obv中的参数180是可以调整的。在此指标中,这次连同一些提示性的信号也一并发出,仅仅供参考,且不可作为操作信号。
资金潮指标 通达信 副图 资金流向 无未来函数 买卖点 操盘控盘 炒股叉第6299张

资金潮指标 通达信 副图 资金流向 无未来函数 买卖点 操盘控盘 炒股叉第6300张

[lywrap=通达信副图指标公式][lycode=tdx,true]STICKLINE(C>0,0,0,10,0),COLORGRAY;
VV:=AMOUNT/100000000;
LB:=MA(VV,1)/HHV(VV,0);
XS:=2;
OBV:=SUM(IF(C>REF(C,1),VV,IF(C<REF(C,1),-VV,0)),180);
WOBV:=EMA(OBV,3);
ROBY:=DMA(OBV,LB/XS);
SOBV:=DMA(OBV,LB/XS/XS);
YOBV:=DMA(OBV,LB/XS/XS/XS);
SSOBC:=DMA(OBV,LB/XS/XS/XS/XS);
LOBV:=DMA(OBV,LB/XS/XS/XS/XS/XS);
QROBV:((SSOBC-LOBV+(YOBV-LOBV)/2+(SOBV-LOBV)/3+(ROBY-LOBV)/4+(WOBV-LOBV)/5)/5),COLOR00CCCC;
MQR:MA(QROBV,8),COLORGRAY;
OBC:((ROBY-LOBV)/2+(SOBV-SSOBC+YOBV-LOBV)/2+WOBV-SOBV)/3,COLOR7F00FF,LINETHICK2;
MOBV:MA(OBC,4),COLORCYAN;
{PARTLINE(OBC<MOBV,OBC),COLOR00BB00,LINETHICK2;}
KOBV:=2*(OBC-MOBV);
DOBV:2*(QROBV-MQR),COLORSTICK;
MACDOBV:(KOBV+DOBV)/2,COLORSTICK,COLORRED;
STICKLINE(MACDOBV>=0,0,MACDOBV,1,1),COLORRED;
STICKLINE(MACDOBV<0,0,MACDOBV,1,1),COLOR00BB00;
STICKLINE(DOBV>=0,0,DOBV,0,0),COLOR00CCCC;
STICKLINE(DOBV<0,0,DOBV,0,0),COLORCYAN;
OBVH1:=REF(MACDOBV/2,BARSLAST(MACDOBV=HHV(MACDOBV,36)));
OBVH2:REF(MACDOBV/2,BARSLAST(MACDOBV=HHV(MACDOBV,72)));
大行情:=NOT(REF(OBVH1,1)=REF(OBVH2,1)) AND OBVH1=OBVH2;
DRAWTEXT(MACDOBV>OBVH1,OBVH2*2,'*'),COLORWHITE;
DRAWTEXT(大行情,OBVH2*4,'★'),COLORRED;
QGOBV:=REF(HHV(MOBV,9),1),COLORFAABEC;
QDOBV:=REF(LLV(MOBV,9),1),COLORAAAA00;
ZJGL:=(((OBC-MOBV)/ABS(MOBV)+(QROBV-MQR)/ABS(MQR)+((OBC-QROBV)/ABS(QROBV)+(MOBV-MQR)/ABS(MQR))/2)/3)*10;
DSGL:=(((OBC-MOBV)/ABS(MOBV)+(OBC-QGOBV)/ABS(QGOBV)+(MOBV-QDOBV)/ABS(QDOBV))/3)*10;
SGL:=(ZJGL+DSGL)/2;
DRAWTEXT(CROSS(ZJGL,0)AND OBC>REF(OBC,1),QROBV*0.8,'★'),COLORYELLOW;
DRAWTEXT(CROSS(DSGL,0)AND OBC>REF(OBC,1) AND OBC>QROBV,QROBV*1.25,'★'),COLORWHITE;[/lycode][lycode=tdx2,true]当满足条件收盘价>0时,在0和0位置之间画柱状线,宽度为10,0不为0则画空心柱.,画深灰色
VV赋值:成交额(元)/100000000
LB赋值:VV的1日简单移动平均/0日内VV的最高值
XS赋值:2
OBV赋值:如果收盘价>1日前的收盘价,返回VV,否则返回如果收盘价<1日前的收盘价,返回-VV,否则返回0的180日累和
WOBV赋值:OBV的3日指数移动平均
ROBY赋值:以LB/XS为权重OBV的动态移动平均
SOBV赋值:以LB/XS/XS为权重OBV的动态移动平均
YOBV赋值:以LB/XS/XS/XS为权重OBV的动态移动平均
SSOBC赋值:以LB/XS/XS/XS/XS为权重OBV的动态移动平均
LOBV赋值:以LB/XS/XS/XS/XS/XS为权重OBV的动态移动平均
输出QROBV:((SSOBC-LOBV+(YOBV-LOBV)/2+(SOBV-LOBV)/3+(ROBY-LOBV)/4+(WOBV-LOBV)/5)/5),COLOR00CCCC
输出MQR:QROBV的8日简单移动平均,画深灰色
输出OBC:((ROBY-LOBV)/2+(SOBV-SSOBC+YOBV-LOBV)/2+WOBV-SOBV)/3,COLOR7F00FF,线宽为2
输出MOBV:OBC的4日简单移动平均,画青色
KOBV赋值:2*(OBC-MOBV)
输出DOBV:2*(QROBV-MQR),COLORSTICK
输出MACDOBV:(KOBV+DOBV)/2,COLORSTICK,画红色
当满足条件MACDOBV>=0时,在0和MACDOBV位置之间画柱状线,宽度为1,1不为0则画空心柱.,画红色
当满足条件MACDOBV<0时,在0和MACDOBV位置之间画柱状线,宽度为1,1不为0则画空心柱.,COLOR00BB00
当满足条件DOBV>=0时,在0和DOBV位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR00CCCC
当满足条件DOBV<0时,在0和DOBV位置之间画柱状线,宽度为0,0不为0则画空心柱.,画青色
OBVH1赋值:上次MACDOBV=36日内MACDOBV的最高值距今天数日前的MACDOBV/2
输出OBVH2:上次MACDOBV=72日内MACDOBV的最高值距今天数日前的MACDOBV/2
大行情赋值:取反 AND OBVH1=OBVH2
当满足条件MACDOBV>OBVH1时,在OBVH2*2位置书写文字,画白色
当满足条件大行情时,在OBVH2*4位置书写文字,画红色
QGOBV赋值:1日前的9日内MOBV的最高值,COLORFAABEC
QDOBV赋值:1日前的9日内MOBV的最低值,COLORAAAA00
ZJGL赋值:(((OBC-MOBV)/MOBV的绝对值+(QROBV-MQR)/MQR的绝对值+((OBC-QROBV)/QROBV的绝对值+(MOBV-MQR)/MQR的绝对值)/2)/3)*10
DSGL赋值:(((OBC-MOBV)/MOBV的绝对值+(OBC-QGOBV)/QGOBV的绝对值+(MOBV-QDOBV)/QDOBV的绝对值)/3)*10
SGL赋值:(ZJGL+DSGL)/2
当满足条件ZJGL上穿0ANDOBC>1日前的OBC时,在QROBV*0.8位置书写文字,画黄色
当满足条件DSGL上穿0ANDOBC>1日前的OBCANDOBC>QROBV时,在QROBV*1.25位置书写文字,画白色[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1irfzUlrzYYuL0XO8SDgPgw

看了该指标的人还看了:
成交量判断趋势指标    大胜算指标
冲破天网指标    梦狼操作系统指标

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表