请选择 进入手机版|继续访问电脑版

买卖收益指标 通达信 主图 无未来函数 买卖点 趋势 操盘控盘

[复制链接]

admin  管理员

发表于 2018-4-12 09:00:09 | 查看全部

指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 无未来函数 买卖点 趋势 操盘控盘 
买卖收益指标 通达信 主图 无未来函数 买卖点 趋势 操盘控盘 炒股叉第6295张

买卖收益指标 通达信 主图 无未来函数 买卖点 趋势 操盘控盘 炒股叉第6296张

[lywrap=通达信主图指标公式][lycode=tdx,true]DRAWTEXT_FIX(1,0.01,0,0,DYBLOCK),COLORYELLOW;
DRAWTEXT_FIX(1,0.15,0,0,HYBLOCK),COLORYELLOW;
DRAWTEXT_FIX(1,0.10,0.0,0,'概念:'),COLORYELLOW;
DRAWTEXT_FIX(1,0.24,0,0,GNBLOCK),COLORYELLOW;
DRAWTEXT_FIX(1,0.01,0.05,0,'风格:'),COLORGREEN;
DRAWTEXT_FIX(1,0.08,0.05,0,FGBLOCK),COLORGREEN;
C2:=REF(C,1);
BG:=IF((C2-C)*100/C2>=2.3,1,0) OR IF((O-C)*100/O>=5,1,0);
BG2:=IF((H-L)*100/C2>=3.58,1,0);
BB1:=L<REF(L,1);
SELL1:=BG AND BB1 ;
BR:=IF((C-C2)*100/C2>=2.59,1,0) OR IF((C-O)*100/O>=4.5,1,0) OR IF((C-L)*100/L>5,1,0);
STICKLINE(BR,O,C,3,0),COLORRED;
DAY1:=BARSLAST(SELL1);
JIA1:=REF(O,DAY1);
JIA2:=REF(O,1);
BB4:=C>JIA2;
BB2:=H>JIA1;
BUY1:=BR AND BB2 AND BB4;
DAY2:=BARSLAST(BUY1);
S1:=DAY1<DAY2;
B1:=DAY2<DAY1;
STICKLINE(S1,O,C,3,0),COLORGREEN;
STICKLINE(B1,H,L,0.3,0),COLORRED;
STICKLINE(B1,O,C,3,1),LINETHICK2,COLORRED;
AA2:=AMOUNT/VOL;
BB3:=L<AA2*0.9;
CC2:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD2:=L<MA(C,6)*0.921;
DD1:=L<MA(C,5)*0.921;
EE2:=VOL<MA(V,5)*1.5;
FF2:=BB3 AND CC2 AND DD2 AND EE2;
STICKLINE(FF2,H,L,0.3,0),COLOR00FFFF;
B4:=BARSLAST(FF2);{底点日期}
E4:=B4<5;{5日内的线}
F4:=E4 AND C>REF(C,1);
STICKLINE(F4,H,L,0.3,0),COLOR00FFFF;
A2:=(C-REF(C,1))/REF(C,1)*100<1.02;
A3:=H>MA(C,5)*1.12;
AA:= A2 AND A3;
DRAWTEXT(AA,H*1.05,'明断推荐卖'),COLOR00FFFF;
STICKLINE(AA,H,L,0.3,0),COLORFF0000;
VAR1:=4*SMA((CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100,5,1)-
3*SMA(SMA((CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100,5,1),3.2,1);
VAR2:=8;
CC:=CROSS(VAR1,VAR2);
CCC:=CROSS(VAR1,VAR2) AND H>REF(H,1) AND C>REF(C,1) ;
DRAWICON(CCC,L*0.99,1);
STICKLINE(CC,H,L,0.3,0),COLORRED;
STICKLINE(CC,O,C,3,1),LINETHICK2,COLORRED;
CF1:=BARSLAST(CC);{买点日期}
CF2:=CF1<3;{5日内的线}
CF3:=CF2 AND C>REF(C,1);
STICKLINE(CF3,O,C,3,0),COLOR00FFFF;
CD:=CROSS(VAR2,VAR1);
STICKLINE(CD,H,L,0.3,0),COLORYELLOW;
STICKLINE(CD,O,C,3,1),LINETHICK2,COLORYELLOW;
DRAWTEXT(CD,H*1.01,''),COLORYELLOW;
DRAWTEXT(CC,L*0.98,'买'),COLORFF00FF;
VAR1A:=LLV(LOW,21);
VAR2A:=HHV(HIGH,21);
AK1:=EMA((((CLOSE - VAR1A) / (VAR2A - VAR1A)) * 100),5);
AK:=EMA((((CLOSE - VAR1A) / (VAR2A - VAR1A)) * 50),13);
AB:=CROSS(AK1,AK);
A:=(3*C+L+O+H)/6;
X:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+
14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+
REF(A,20))/210;
S2:=SMA(C,3,1);
S6:=SMA(C,5,1);
DK:=2*(S2-S6);
主力成本:EMA(X,13),LINETHICK1,COLORLIGRAY;
强力支撑:LLV(HIGH,30),LINETHICK2,COLORFFCC00;
VAR3AA:=IF((CLOSE>REF(CLOSE,1)),88,0);
VAR4AA:=IF(((CLOSE)/(REF(CLOSE,1))>1.05) AND ((HIGH)/(CLOSE)<1.01) AND (VAR3AA>0),91,0);
DRAWTEXT(FILTER((VAR4AA>90),45),(LOW)*(0.93),'★大胆进场 '),COLOR00FFFF;
DRAWTEXT(FILTER((VAR4AA>90),35),(LOW)*(0.99000001),'★大胆加仓'),COLOR00FFFF;
A1AA:=9;
A2AA:=(REF(CLOSE,A1AA+1)<CLOSE);
VAR6:=REF(C,1);
VAR7:=SMA(MAX(C-VAR6,0),6,1)/SMA(ABS(C-VAR6),6,1)*100;
DRAWTEXT(CROSS(82,VAR7),H*1.02,'逃顶'),COLORYELLOW;
VAR9:=((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100);
VAR10:=SMA(VAR9,3,1);
VAR11:=SMA(VAR10,3,1);
VAR12:=SMA(VAR11,3,1);
A1A:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*1,5,1)-2*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*1,5,1),COLOR330066;
A5A:=(HHV(H,60)-C)/(HHV(H,60)-LLV(L,60))*1;
DRAWTEXT(CROSS(A1A,EMA(A1A,5))AND EMA(A1A,5)<A5A,L*0.98,'起爆'),COLORYELLOW;
VV2:=REF(CLOSE,1);
VV3:=SMA((CLOSE-VV2),6,1)/SMA(ABS(CLOSE-VV2),6,1)*100;
DRAWICON(REF(VV3,1)>81 AND VV3<80,HIGH,2);
VF1:=MA(CLOSE,60)-MA(CLOSE,5)/3.2;
VVARA:=(CLOSE-REF(OPEN,29))/REF(OPEN,29)*100;
VVARB:=EMA(0.667*REF(VVARA,1)+0.333*VVARA,5);
DRAWTEXT(IF(VOL>=1.3*MA(VOL,5) AND COUNT(VVARA>=VVARB AND VVARA<-17,3) AND REF(LOW,1)=LLV(LOW,120),1,0),LOW,'★注意买入');
VVARR1:=SMA(MAX(CLOSE-REF(C,1),0),6,1)/SMA(ABS(CLOSE-REF(C,1)),6,1)*100;
DRAWICON(CROSS(82,VVARR1),HIGH,2);
DRAWTEXT(CROSS(82,VVARR1),HIGH,''),COLORYELLOW;
VVAR1:=(HIGH+LOW+OPEN+2*CLOSE)/5;
VVAR2:=REF(VVAR1,1);
VVAR3:=SMA(MAX(VVAR1-VVAR2,0),10,1)/SMA(ABS(VVAR1-VVAR2),10,1)*100;
HY3:=IF(COUNT(VVAR3<20,5)>=1 AND COUNT(VVAR1=LLV(VVAR1,10),10)>=1 AND CLOSE>=OPEN*1.038 AND VOL>MA(VOL,5)*1.2,1,0);
DRAWTEXT(HY3,LOW,' 注意机会'),COLORRED;[/lycode][lycode=tdx2,true]当满足条件1时,在横轴0.01纵轴0位置书写文字,画黄色
当满足条件1时,在横轴0.15纵轴0位置书写文字,画黄色
当满足条件1时,在横轴0.10纵轴0.0位置书写文字,画黄色
当满足条件1时,在横轴0.24纵轴0位置书写文字,画黄色
当满足条件1时,在横轴0.01纵轴0.05位置书写文字,画绿色
当满足条件1时,在横轴0.08纵轴0.05位置书写文字,画绿色
C2赋值:1日前的收盘价
BG赋值:如果(C2-收盘价)*100/C2>=2.3,返回1,否则返回0 OR 如果(开盘价-收盘价)*100/开盘价>=5,返回1,否则返回0
BG2赋值:如果(最高价-最低价)*100/C2>=3.58,返回1,否则返回0
BB1赋值:最低价<1日前的最低价
SELL1赋值:BG AND BB1
BR赋值:如果(收盘价-C2)*100/C2>=2.59,返回1,否则返回0 OR 如果(收盘价-开盘价)*100/开盘价>=4.5,返回1,否则返回0 OR 如果(收盘价-最低价)*100/最低价>5,返回1,否则返回0
当满足条件BR时,在开盘价和收盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,画红色
DAY1赋值:上次SELL1距今天数
JIA1赋值:DAY1日前的开盘价
JIA2赋值:1日前的开盘价
BB4赋值:收盘价>JIA2
BB2赋值:最高价>JIA1
BUY1赋值:BR AND BB2 AND BB4
DAY2赋值:上次BUY1距今天数
S1赋值:DAY1<DAY2
B1赋值:DAY2<DAY1
当满足条件S1时,在开盘价和收盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,画绿色
当满足条件B1时,在最高价和最低价位置之间画柱状线,宽度为0.3,0不为0则画空心柱.,画红色
当满足条件B1时,在开盘价和收盘价位置之间画柱状线,宽度为3,1不为0则画空心柱.,线宽为2,画红色
AA2赋值:成交额(元)/成交量(手)
BB3赋值:最低价<AA2*0.9
CC2赋值:(收盘价-1日前的收盘价)/1日前的收盘价*100>1.2
DD2赋值:最低价<收盘价的6日简单移动平均*0.921
DD1赋值:最低价<收盘价的5日简单移动平均*0.921
EE2赋值:成交量(手)<成交量(手)的5日简单移动平均*1.5
FF2赋值:BB3 AND CC2 AND DD2 AND EE2
当满足条件FF2时,在最高价和最低价位置之间画柱状线,宽度为0.3,0不为0则画空心柱.,COLOR00FFFF
B4赋值:上次FF2距今天数
E4赋值:B4<5
F4赋值:E4 AND 收盘价>1日前的收盘价
当满足条件F4时,在最高价和最低价位置之间画柱状线,宽度为0.3,0不为0则画空心柱.,COLOR00FFFF
A2赋值:(收盘价-1日前的收盘价)/1日前的收盘价*100<1.02
A3赋值:最高价>收盘价的5日简单移动平均*1.12
AA赋值: A2 AND A3
当满足条件AA时,在最高价*1.05位置书写文字,COLOR00FFFF
当满足条件AA时,在最高价和最低价位置之间画柱状线,宽度为0.3,0不为0则画空心柱.,COLORFF0000
VAR1赋值:4*(收盘价-5日内最低价的最低值)/(5日内最高价的最高值-5日内最低价的最低值)*100的5日[1日权重]移动平均-3*(收盘价-5日内最低价的最低值)/(5日内最高价的最高值-5日内最低价的最低值)*100的5日[1日权重]移动平均的3.2日[1日权重]移动平均
VAR2赋值:8
CC赋值:VAR1上穿VAR2
CCC赋值:VAR1上穿VAR2 AND 最高价>1日前的最高价 AND 收盘价>1日前的收盘价
当满足条件CCC时,在最低价*0.99位置画1号图标
当满足条件CC时,在最高价和最低价位置之间画柱状线,宽度为0.3,0不为0则画空心柱.,画红色
当满足条件CC时,在开盘价和收盘价位置之间画柱状线,宽度为3,1不为0则画空心柱.,线宽为2,画红色
CF1赋值:上次CC距今天数
CF2赋值:CF1<3
CF3赋值:CF2 AND 收盘价>1日前的收盘价
当满足条件CF3时,在开盘价和收盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR00FFFF
CD赋值:VAR2上穿VAR1
当满足条件CD时,在最高价和最低价位置之间画柱状线,宽度为0.3,0不为0则画空心柱.,画黄色
当满足条件CD时,在开盘价和收盘价位置之间画柱状线,宽度为3,1不为0则画空心柱.,线宽为2,画黄色
当满足条件CD时,在最高价*1.01位置书写文字,画黄色
当满足条件CC时,在最低价*0.98位置书写文字,COLORFF00FF
VAR1A赋值:21日内最低价的最低值
VAR2A赋值:21日内最高价的最高值
AK1赋值:(((收盘价-VAR1A)/(VAR2A-VAR1A))*100)的5日指数移动平均
AK赋值:(((收盘价-VAR1A)/(VAR2A-VAR1A))*50)的13日指数移动平均
AB赋值:AK1上穿AK
A赋值:(3*收盘价+最低价+开盘价+最高价)/6
X赋值:(20*A+19*1日前的A+18*2日前的A+17*3日前的A+16*4日前的A+15*5日前的A+14*6日前的A+13*7日前的A+12*8日前的A+11*9日前的A+10*10日前的A+9*11日前的A+8*12日前的A+7*13日前的A+6*14日前的A+5*15日前的A+4*16日前的A+3*17日前的A+2*18日前的A+20日前的A)/210
S2赋值:收盘价的3日[1日权重]移动平均
S6赋值:收盘价的5日[1日权重]移动平均
DK赋值:2*(S2-S6)
输出主力成本:X的13日指数移动平均,线宽为1,画淡灰色
输出强力支撑:30日内最高价的最低值,线宽为2,COLORFFCC00
VAR3AA赋值:如果(收盘价>1日前的收盘价),返回88,否则返回0
VAR4AA赋值:如果((收盘价)/(1日前的收盘价)>1.05)AND((最高价)/(收盘价)<1.01)AND(VAR3AA>0),返回91,否则返回0
当满足条件(VAR4AA>90)的45日过滤时,在(最低价)*(0.93)位置书写文字,COLOR00FFFF
当满足条件(VAR4AA>90)的35日过滤时,在(最低价)*(0.99000001)位置书写文字,COLOR00FFFF
A1AA赋值:9
A2AA赋值:(A1AA+1日前的收盘价<收盘价)
VAR6赋值:1日前的收盘价
VAR7赋值:收盘价-VAR6和0的较大值的6日[1日权重]移动平均/收盘价-VAR6的绝对值的6日[1日权重]移动平均*100
当满足条件82上穿VAR7时,在最高价*1.02位置书写文字,画黄色
VAR9赋值:((收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值))*(100)
VAR10赋值:VAR9的3日[1日权重]移动平均
VAR11赋值:VAR10的3日[1日权重]移动平均
VAR12赋值:VAR11的3日[1日权重]移动平均
A1A赋值:3*(收盘价-55日内最低价的最低值)/(55日内最高价的最高值-55日内最低价的最低值)*1的5日[1日权重]移动平均-2*(收盘价-55日内最低价的最低值)/(55日内最高价的最高值-55日内最低价的最低值)*1的5日[1日权重]移动平均,COLOR330066
A5A赋值:(60日内最高价的最高值-收盘价)/(60日内最高价的最高值-60日内最低价的最低值)*1
当满足条件A1A上穿A1A的5日指数移动平均ANDEMA(A1A,5)<A5A时,在最低价*0.98位置书写文字,画黄色
VV2赋值:1日前的收盘价
VV3赋值:(收盘价-VV2)的6日[1日权重]移动平均/收盘价-VV2的绝对值的6日[1日权重]移动平均*100
当满足条件1日前的VV3>81ANDVV3<80时,在最高价位置画2号图标
VF1赋值:收盘价的60日简单移动平均-收盘价的5日简单移动平均/3.2
VVARA赋值:(收盘价-29日前的开盘价)/29日前的开盘价*100
VVARB赋值:0.667*1日前的VVARA+0.333*VVARA的5日指数移动平均
当满足条件如果成交量(手)>=1.3*成交量(手)的5日简单移动平均ANDCOUNT(VVARA>=VVARBANDVVARA<-17,3)ANDREF(最低价,1)=120日内最低价的最低值,返回1,否则返回0时,在最低价位置书写文字
VVARR1赋值:收盘价-1日前的收盘价和0的较大值的6日[1日权重]移动平均/收盘价-1日前的收盘价的绝对值的6日[1日权重]移动平均*100
当满足条件82上穿VVARR1时,在最高价位置画2号图标
当满足条件82上穿VVARR1时,在最高价位置书写文字,画黄色
VVAR1赋值:(最高价+最低价+开盘价+2*收盘价)/5
VVAR2赋值:1日前的VVAR1
VVAR3赋值:VVAR1-VVAR2和0的较大值的10日[1日权重]移动平均/VVAR1-VVAR2的绝对值的10日[1日权重]移动平均*100
HY3赋值:如果统计5日中满足VVAR3<20的天数>=1ANDCOUNT(VVAR1=10日内VVAR1的最低值,10)>=1ANDCLOSE>=开盘价*1.038ANDVOL>成交量(手)的5日简单移动平均*1.2,返回1,否则返回0
当满足条件HY3时,在最低价位置书写文字,画红色[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1Lqr0N9dlyaCPkX3cStaq6g

看了该指标的人还看了:
逃顶抄底指标    绝对超底指标
趋势抄底指标    波段火焰山指标

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表