请选择 进入手机版|继续访问电脑版

顶底趋势精心收藏的好指标 通达信 副图

[复制链接]

admin  管理员

发表于 2017-7-4 10:03:47 | 查看全部

指标公式
软件: 通达信 
公式类型: 副图 
二级分类:  
顶底趋势精心收藏的好指标 通达信 副图 炒股叉第57张
顶底趋势精心收藏的好指标 通达信 副图 炒股叉第58张

顶底趋势精心收藏的好指标 通达信 副图 炒股叉第59张


[lycode=tdx,true]趋势:SMA(((CLOSE-LLV(LOW,28))/(HHV(HIGH,28)-LLV(LOW,28))*100),3,1) ,COLORGREEN;
STICKLINE(趋势>50,趋势,50,4,0),COLOR32329B;
STICKLINE(50>趋势,趋势,50,4,0),COLOR326400;
IF(趋势>50, 趋势,DRAWNULL), COLORRED;
RSV:=(CLOSE-LLV(CLOSE,9))/(HHV(CLOSE,9)-LLV(CLOSE,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
TYP:=(HIGH+LOW+CLOSE)/3;
CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));
DIFF:=EMA(CLOSE,2)-EMA(CLOSE,55);
DEA:=EMA(DIFF,6);
MACD:=2*(DIFF-DEA);
转点:=IF(K>D AND CCI>0 AND DIFF>DEA AND MACD>0,1,0);
STICKLINE(转点=1,50,50,6,0),COLORYELLOW;
STICKLINE(转点=0,50,50,6,0),COLORCYAN;
顶部:90,COLORYELLOW;
底部:10,COLORCYAN;
判断:SMA(趋势,3,1),COLORFF00FF, LINETHICK2;
IF( 趋势>判断,判断,DRAWNULL), COLORYELLOW, LINETHICK2;
IF( 趋势<判断,判断,DRAWNULL) ,COLORFFF000,LINETHICK2;
DRAWICON(CROSS(趋势,判断),判断,1);
DRAWICON(CROSS(趋势,顶部),顶部,2);
LC:= REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
VAR1:=(HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9))*100-70;
VAR2:=SMA(VAR1,9,1)+100;
VAR3:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR4:=SMA(VAR3,3,1);
VAR5:=SMA(VAR4,3,1)+100;
VAR6:=VAR5-VAR2;
短线1: IF(VAR6>45,VAR6-45,0),COLORA6B8C1;
VAR2Q:=REF(LOW,1);
VAR3Q:=SMA(ABS(LOW-VAR2Q),3,1)/SMA(MAX(LOW-VAR2Q,0),3,1)*100;
VAR4Q:=EMA(IF(CLOSE*1.3,VAR3Q*10,VAR3Q/10),3);
VAR5Q:=LLV(LOW,30);
VAR6Q:=HHV(VAR4Q,30);
VAR7Q:=IF(MA(CLOSE,58),1,0);
VAR8Q:=EMA(IF(LOW<=VAR5Q,(VAR4Q+VAR6Q*2)/2,0),3)/999*VAR7Q;
VR2:=REF(LOW,1);
VR3:=SMA(ABS(LOW-VR2),3,1)/SMA(MAX(LOW-VR2,0),3,1)*100;
VR4:=EMA(IF(CLOSE*1.3,VR3*10,VR3/10),3);
VR5:=LLV(LOW,30);
VR6:=HHV(VR4,30);
VR7:=IF(MA(CLOSE,58),1,0);
VR8:=EMA(IF(LOW<=VR5,(VR4+VR6*2)/2,0),3)/618*VR7;
VR9:=IF(VR8>100,100,VR8);
主力进场:STICKLINE(VR9>-150,0,VR9,3,0), , COLORFF00FF;
洗盘:IF(VR9<REF(VR9,1),VR9,0),COLORGREEN,NODRAW;
STICKLINE(VR9<REF(VR9,1),0,VR9,3,0),COLORGREEN;
短线获利:STICKLINE(REF("KDJ.J",1)<0 AND "KDJ.J">0,60,25,2,0),COLORYELLOW;
VARK1:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
VARK2:=REVERSE(VARK1);
VARK3:=SMA(VARK1,3,1);

逃顶:=CROSS(82,RSI);
STICKLINE( 逃顶,逃顶,20,5,0),COLORFF5500;
STICKLINE( 逃顶,逃顶,30,3,0),COLORFF8800;
STICKLINE( 逃顶,逃顶,30,2,0),COLORFFAA00;
STICKLINE( 逃顶,逃顶,30,1,0),COLORFFCC00;
D1:=(C+L+H)/3;
D2:=EMA(D1,6);
D3:=EMA(D2,5);
BBUY:=CROSS(D2,D3);
风险区:80,COLORFF85FF;
安全区:20,COLORYELLOW,POINTDOT;
天线:100,COLORFFFF00;
强弱线:50,COLORGREEN,POINTDOT;
DRAWICON(BBUY,(LOW *1),1);
VARR1:=SMA(MAX(CLOSE-REF(C,1),0),6,1)/SMA(ABS(CLOSE-REF(C,1)),6,1)*100;
DRAWICON(CROSS(82,VARR1),HIGH,15);
DRAWTEXT(CROSS(82,VARR1),35,'逃'),COLORYELLOW;
MAV:=(2*C+H+L)/4;
VAR9:=LLV(LOW,34);
VAR7:=HHV(HIGH,34);
SK:= EMA((MAV-VAR9)/(VAR7-VAR9)*100,13);
SD: EMA(0.667*REF(SK,1)+0.333*SK,2);
高抛:80, POINTDOT;
低吸:20, POINTDOT;
强弱分界:50, POINTDOT;
DRAWTEXT(CROSS(SD,16),低吸,'●主力'),COLORF0FF00,LINETHICK3;[/lycode]

解释:
[lycode=tdx,true]输出趋势:((收盘价-28日内最低价的最低值)/(28日内最高价的最高值-28日内最低价的最低值)*100)的3日[1日权重]移动平均 ,画绿色
当满足条件趋势>50时,在趋势和50位置之间画柱状线,宽度为4,0不为0则画空心柱.,COLOR32329B
当满足条件50>趋势时,在趋势和50位置之间画柱状线,宽度为4,0不为0则画空心柱.,COLOR326400
如果趋势>50,返回趋势,否则返回无效数, 画红色
RSV赋值:(收盘价-9日内收盘价的最低值)/(9日内收盘价的最高值-9日内收盘价的最低值)*100
K赋值:RSV的3日[1日权重]移动平均
D赋值:K的3日[1日权重]移动平均
TYP赋值:(最高价+最低价+收盘价)/3
CCI赋值:(TYP-TYP的14日简单移动平均)/(0.015*TYP的14日平均绝对偏差)
DIFF赋值:收盘价的2日指数移动平均-收盘价的55日指数移动平均
DEA赋值:DIFF的6日指数移动平均
MACD赋值:2*(DIFF-DEA)
转点赋值:如果K>DANDCCI>0ANDDIFF>DEAANDMACD>0,返回1,否则返回0
当满足条件转点=1时,在50和50位置之间画柱状线,宽度为6,0不为0则画空心柱.,画黄色
当满足条件转点=0时,在50和50位置之间画柱状线,宽度为6,0不为0则画空心柱.,画青色
输出顶部:90,画黄色
输出底部:10,画青色
输出判断:趋势的3日[1日权重]移动平均,COLORFF00FF, 线宽为2
如果趋势>判断,返回判断,否则返回无效数, 画黄色, 线宽为2
如果趋势<判断,返回判断,否则返回无效数 ,COLORFFF000,线宽为2
当满足条件趋势上穿判断时,在判断位置画1号图标
当满足条件趋势上穿顶部时,在顶部位置画2号图标
LC赋值: 1日前的收盘价
RSI赋值:收盘价-LC和0的较大值的6日[1日权重]移动平均/收盘价-LC的绝对值的6日[1日权重]移动平均*100
VAR1赋值:(9日内最高价的最高值-收盘价)/(9日内最高价的最高值-9日内最低价的最低值)*100-70
VAR2赋值:VAR1的9日[1日权重]移动平均+100
VAR3赋值:(收盘价-9日内最低价的最低值)/(9日内最高价的最高值-9日内最低价的最低值)*100
VAR4赋值:VAR3的3日[1日权重]移动平均
VAR5赋值:VAR4的3日[1日权重]移动平均+100
VAR6赋值:VAR5-VAR2
输出短线1: 如果VAR6>45,返回VAR6-45,否则返回0,COLORA6B8C1
VAR2Q赋值:1日前的最低价
VAR3Q赋值:最低价-VAR2Q的绝对值的3日[1日权重]移动平均/最低价-VAR2Q和0的较大值的3日[1日权重]移动平均*100
VAR4Q赋值:如果收盘价*1.3,返回VAR3Q*10,否则返回VAR3Q/10的3日指数移动平均
VAR5Q赋值:30日内最低价的最低值
VAR6Q赋值:30日内VAR4Q的最高值
VAR7Q赋值:如果收盘价的58日简单移动平均,返回1,否则返回0
VAR8Q赋值:如果最低价<=VAR5Q,返回(VAR4Q+VAR6Q*2)/2,否则返回0的3日指数移动平均/999*VAR7Q
VR2赋值:1日前的最低价
VR3赋值:最低价-VR2的绝对值的3日[1日权重]移动平均/最低价-VR2和0的较大值的3日[1日权重]移动平均*100
VR4赋值:如果收盘价*1.3,返回VR3*10,否则返回VR3/10的3日指数移动平均
VR5赋值:30日内最低价的最低值
VR6赋值:30日内VR4的最高值
VR7赋值:如果收盘价的58日简单移动平均,返回1,否则返回0
VR8赋值:如果最低价<=VR5,返回(VR4+VR6*2)/2,否则返回0的3日指数移动平均/618*VR7
VR9赋值:如果VR8>100,返回100,否则返回VR8
输出主力进场:当满足条件VR9>-150时,在0和VR9位置之间画柱状线,宽度为3,0不为0则画空心柱., , COLORFF00FF
输出洗盘:如果VR9<1日前的VR9,返回VR9,否则返回0,画绿色,NODRAW
当满足条件VR9<1日前的VR9时,在0和VR9位置之间画柱状线,宽度为3,0不为0则画空心柱.,画绿色
输出短线获利:当满足条件1日前的"KDJ的J"<0AND"KDJ的J">0时,在60和25位置之间画柱状线,宽度为2,0不为0则画空心柱.,画黄色
VARK1赋值:(收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值)*100
VARK2赋值:VARK1的相反数
VARK3赋值:VARK1的3日[1日权重]移动平均
逃顶赋值:82上穿RSI
当满足条件逃顶时,在逃顶和20位置之间画柱状线,宽度为5,0不为0则画空心柱.,COLORFF5500
当满足条件逃顶时,在逃顶和30位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLORFF8800
当满足条件逃顶时,在逃顶和30位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLORFFAA00
当满足条件逃顶时,在逃顶和30位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLORFFCC00
D1赋值:(收盘价+最低价+最高价)/3
D2赋值:D1的6日指数移动平均
D3赋值:D2的5日指数移动平均
BBUY赋值:D2上穿D3
输出风险区:80,COLORFF85FF
输出安全区:20,画黄色,POINTDOT
输出天线:100,COLORFFFF00
输出强弱线:50,画绿色,POINTDOT
当满足条件BBUY时,在(最低价*1)位置画1号图标
VARR1赋值:收盘价-1日前的收盘价和0的较大值的6日[1日权重]移动平均/收盘价-1日前的收盘价的绝对值的6日[1日权重]移动平均*100
当满足条件82上穿VARR1时,在最高价位置画15号图标
当满足条件82上穿VARR1时,在35位置书写文字,画黄色
MAV赋值:(2*收盘价+最高价+最低价)/4
VAR9赋值:34日内最低价的最低值
VAR7赋值:34日内最高价的最高值
SK赋值: (MAV-VAR9)/(VAR7-VAR9)*100的13日指数移动平均
输出SD: 0.667*1日前的SK+0.333*SK的2日指数移动平均
输出高抛:80, POINTDOT
输出低吸:20, POINTDOT
输出强弱分界:50, POINTDOT
当满足条件SD上穿16时,在低吸位置书写文字,COLORF0FF00,线宽为3
[/lycode]

下载地址:
游客,如果您要查看本帖隐藏内容请回复


看了该指标的人还看了:
买卖提示指标    红白持仓指标
最佳综合顶底指标    牛起步指标

举报 使用道具

回复

精彩评论3

cgx_xhtc  中级会员

发表于 2018-9-28 13:45:09 | 显示全部楼层

谢谢!楼主分享!

举报 使用道具

回复

bluehcy  新手上路

发表于 2018-12-1 18:25:33 | 显示全部楼层

顶底趋势精心收藏的好指

举报 使用道具

回复

qiang...............

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表