请选择 进入手机版|继续访问电脑版

123战法/三买选股公式/强势形态/收敛突破/选股指标 通达信 主图 选股

  [复制链接]

admin  管理员

发表于 2017-7-2 17:21:15 | 查看全部

指标公式
软件: 通达信 
公式类型: 主图 选股 
二级分类:  
一、市场分析:
现在我们看看大盘行情吧,今天上证指数今以价平量增收T星,并留长下影,量价配合暗示趋势走入阶段止跌过程,个人认为二,三天走势将会出现,并以出小阴小阳走势为居多,操作上,后二,三天以短线逢低买入为主,注意适量仓位参与,毕竞大盘趋势依旧处于弱势状态,小趋势先服从大势,是否改变扭转仍有待观察,先当弱反抽行情看,趋势者必须观望为生。

二、123——战法
今天给大家分享的是123战法,该战法包含1个主图指标,1个副图指标,4个选股公式。此外主图指标包含未来函数BACKSET,COST和DRAWLINE三个未来函数,但是不影响是用,这和大家提前声明一下哦。下面我们先看看实战案例:

三、“123——战法”实战案例:
以下为我随意挑选的几张图片,为大家展示“123——战法”指标导入后的显示情况,供大家参考!
123战法/三买选股公式/强势形态/收敛突破/选股指标 通达信 主图 选股 炒股叉第41张

123战法/三买选股公式/强势形态/收敛突破/选股指标 通达信 主图 选股 炒股叉第42张

123战法/三买选股公式/强势形态/收敛突破/选股指标 通达信 主图 选股 炒股叉第40张

123战法/三买选股公式/强势形态/收敛突破/选股指标 通达信 主图 选股 炒股叉第43张

123战法/三买选股公式/强势形态/收敛突破/选股指标 通达信 主图 选股 炒股叉第44张


四、指标用法:

一、主图指标信号说明:
123战法:综合了趋势理论、道氏理论、波浪理论、 缠论等常用的形态结构分析战法。运用通达信特有的画线函数画出波段高低点线段,直观显示K线的形态结构便于投资分析决策。运用独特的函数算法,求出波段高低点的值进行排列对比,从而实现各种形态选股条件。
1、主图左上角:显示最近四段的周期及涨跌幅----直观显示每段的周期、涨跌幅便于对比分析。
2、黄色实线:波段高低点连线-----便于观察K线的形态结构。
3、水平虚线:波段高低点价格向右水平延伸-----便于观察当前价与前波高低点的关系。

二、参数设置:
1、M1、M2、M3、M4:移动平均线。可添加自己常用的均线【0为不显示】
2、笔周期:参数越大选的笔周期越长【建议用:3-5】
3、画趋势:最近高点与高点、底点与低点连线。【1为显示、0为不显示】
4、涨停位:在最近的涨K线上求出相应价格向右线黄色虚线【0为涨停K线的最低价、50表示涨停K线的中间价、100为涨停K线的最高价】----可实现《涨停战法》相关条件选股。
5、半分位:最近一段涨跌幅的相应价格向右画浅绿实线【0为段的最低价、50为段的中间价、100为段的最高价】----可以实战《黄金分割战法》的相关条件选股。
6、成本线:移动筹码分布的平均成本【1为显示、0为显示】-----直接观显示流通筹码的平均成本变化。
以上是选股预警四种形态简示图。其他形态选股可以结合个人实战经验进行增加。本战法体系包含一个副图、一个主图和三个选股指标,如下图所示:

五、“指标”核心副图:温馨提示:该指标为副图,必须第一个导入,且名称为“指标”!否者123战法指标公式导入会提示错误。

123战法 指标源码(主图):
[lycode=tdx,true]{智能版:="核心指标.VAR100#DAY";}
智能版:="指标.核心#DAY";
MA1:MA(CLOSE,M1),COLORWHITE;
MA2:MA(CLOSE,M2),COLORYELLOW;
MA3:MA(CLOSE,M3),COLORCYAN;
MA4:MA(CLOSE,M4),COLORCYAN;
成本:((COST(90)+COST(70)+COST(50)+COST(30)+COST(10))/5)*成本线,LINETHICK2,COLORWHITE;
{阳线上下影}
STICKLINE(CLOSE*成本线>=OPEN,CLOSE,HIGH,0,0), COLORRED;
STICKLINE(CLOSE*成本线>=OPEN,OPEN,LOW,0,0), COLORRED;
{阴线上下影}
STICKLINE(CLOSE<OPEN*成本线,OPEN,HIGH,0,0), COLOR00EC00;
STICKLINE(CLOSE<OPEN*成本线,CLOSE,LOW,0,0), COLOR00EC00;
{阳K线}
STICKLINE(CLOSE*成本线>=OPEN,CLOSE,OPEN,2.9.2,0),COLOR0000A1;
STICKLINE(CLOSE*成本线>=OPEN,CLOSE,OPEN,1.9.2,0),COLOR0000B5;
STICKLINE(CLOSE*成本线>=OPEN,CLOSE,OPEN,0.9.8,0),COLOR0000C5;
STICKLINE(CLOSE*成本线>=OPEN,CLOSE,OPEN,0.4,0),COLOR0000D4;
STICKLINE(CLOSE*成本线>=OPEN,CLOSE,OPEN,0.2,0),COLOR0000FF;
{阴K线}
STICKLINE(CLOSE<OPEN*成本线,CLOSE,OPEN,2.9.2,0),COLOR009000;
STICKLINE(CLOSE<OPEN*成本线,CLOSE,OPEN,1.9.2,0),COLOR00B400;
STICKLINE(CLOSE<OPEN*成本线,CLOSE,OPEN,0.9.8,0),COLOR00C100;
STICKLINE(CLOSE<OPEN*成本线,CLOSE,OPEN,0.4,0),COLOR00DB00;
STICKLINE(CLOSE<OPEN*成本线,CLOSE,OPEN,0.2,0),COLOR00EC00;

日线:=IF(PERIOD=5,1,0);
CA3:=REF(C,1)*日线;
涨停:=IF((C-CA3)*100/CA3>=(10-0.01*100/CA3),1,0);
STICKLINE(涨停,OPEN,CLOSE,2.9.1,1),COLORYELLOW;
跌停:=IF((CA3-C)*100/CA3>=(10-0.01*100/CA3),1,0);
STICKLINE(跌停,OPEN,CLOSE,2.9.1,0),COLORCYAN;
A1:=REF(HIGH,3)=HHV(HIGH,笔周期*3+1)*智能版;
B1:=FILTER(A1,3); C1:=BACKSET(B1,3+1);
D1:=FILTER(C1,3);{高点}
A2:=REF(LOW,3)=LLV(LOW,笔周期*3+1)*智能版;
B2:=FILTER(A2,3); C2:=BACKSET(B2,3+1);
D2:=FILTER(C2,3);{低点}
E1:=(REF(LLV(LOW,2*3),1)+REF(HHV(HIGH,2*3),1))/2;
E2:=(HIGH+LOW)/2;{高低点出现在同一K线上时可作取舍}
H1:=(D1 AND NOT(D2 AND E1>=E2)) OR BARSTATUS=2 OR BARSCOUNT(CLOSE)=1;
H2:=D1 AND NOT(D2 AND E1>=E2);
L1:=D2 AND NOT(D1 AND E1=E2);
X1:=REF(BARSLAST(H1),1)+1;
F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,LOW,10000),X1));
G1:=F1>REF(F1,1);
I1:=BACKSET(G1,2);
LD:=I1>REF(I1,1);{过滤后低点}
L2:=LD OR BARSTATUS=2 OR BARSCOUNT(CLOSE)=1;
X2:=REF(BARSLAST(L2),1)+1;
F2:=BACKSET(L2 AND COUNT(H2,X2)>0,HHVBARS(IF(H2,HIGH,0),X2));
G2:=F2>REF(F2,1);
I2:=BACKSET(G2,2);
HD:=I2>REF(I2,1);{过滤后高点}
DRAWLINE(LD,L,HD,H,0),COLORYELLOW,LINETHICK1;
DRAWLINE(HD,H,LD,L,0),COLORYELLOW,LINETHICK1;
J1:=BACKSET(BARSTATUS=2,MIN(BARSLAST(HD),BARSLAST(LD))+1);
J2:=J1>REF(J1,1);

A3:=H;
B3:=REF(H,REF(BARSLAST(HD),1)+1)>REF(H,REF(BARSLAST(HD),1)+2+REF(BARSLAST(HD),REF(BARSLAST(HD),1)+2));
D3:=A3 AND B3 AND HD;
E3:=BACKSET(D3,REF(BARSLAST(HD),1)+2);
HH:=E3>REF(E3,1);{找出全部长期高点}
A4:=L>REF(L,REF(BARSLAST(LD),1)+1);
B4:=REF(L,REF(BARSLAST(LD),1)+1);
D4:=A4 AND B4 AND LD;
E4:=BACKSET(D4,REF(BARSLAST(LD),1)+2);
LL:=E4>REF(E4,1);{找出全部长期低点}
H3:=HH OR BARSTATUS=2 OR BARSCOUNT(C)=1; {后面进行过滤,方法同前。只是不用考虑高低点出现在同一K线}
X3:=REF(BARSLAST(H3),1)+1;
F3:=BACKSET(H3 AND COUNT(LL,X3)>0,LLVBARS(IF(LL,L,POW(10,20)),X3));
G3:=F3>REF(F3,1); I3:=BACKSET(G3,2);
LZ:=I3>REF(I3,1); {长期低点,也可供引用}
L4:=LZ OR BARSTATUS=2 OR BARSCOUNT(C)=1;
X4:=REF(BARSLAST(L4),1)+1;
F4:=BACKSET(L4 AND COUNT(HH,X4)>0,HHVBARS(IF(HH,H,-POW(10,20)),X4));
G4:=F4>REF(F4,1); I4:=BACKSET(G4,2); HZ:=I4>REF(I4,1);{长期高点,也可供引用}
{DRAWLINE(HZ,H,LZ,L,0),COLORGREEN,LINETHICK1;
DRAWLINE(LZ,L,HZ,H,0),COLORGREEN,LINETHICK1;长期连线}
K1:=BACKSET(BARSTATUS=2,MIN(BARSLAST(HZ),BARSLAST(LZ))+1); K2:=K1>REF(K1,1);
{DRAWLINE(K2,IF(HZ,H,L),BARSTATUS=2,C,0),COLORGREEN,LINETHICK1; 最后的长期连线,连在收盘价上}
UU:=BACKSET(BARSTATUS=2,BARSLAST(LD)+1);
VV:=UU>REF(UU,1);
WW:=BACKSET(VV,REF(BARSLAST(LD),1)+2);
XX:=WW>REF(WW,1);
WWQ:=BACKSET(XX,REF(BARSLAST(LD),1)+2);
XXQ:=WWQ>REF(WWQ,1);
下轨:DRAWLINE(XX,L,VV,L,1)*画趋势,COLORMAGENTA,LINETHICK1;{画趋势线}
UU2:=BACKSET(BARSTATUS=2,BARSLAST(HD)+1);
VV2:=UU2>REF(UU2,1);
WW2:=BACKSET(VV2,REF(BARSLAST(HD),1)+2);
XX2:=WW2>REF(WW2,1);
WW3Q:=BACKSET(XX2,REF(BARSLAST(HD),1)+2);
XX3Q:=WW3Q>REF(WW3Q,1);
WW4Q:=BACKSET(XX3Q,REF(BARSLAST(HD),1)+2);
XX4Q:=WW4Q>REF(WW4Q,1);
上轨:DRAWLINE(XX2,H,VV2,H,1)*画趋势,COLORMAGENTA,LINETHICK1;{画趋势线}
上轨1:=DRAWLINE(XX2,H,VV2,H,1);

Q0:=BARSLAST(XX2>0);
Q1:=BARSLAST(XX>0);
Q2:=BARSLAST(WW2>0);
Q3:=BARSLAST(VV>0);
Q4:=BARSLAST(XXQ>0);
Q5:=BARSLAST(XX3Q>0);
Q6:=BARSLAST(XX4Q>0);
OA周:=Q0-Q1+1;AB周:=Q1-Q2+1;BC周:=Q2-Q3+1;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(Q5)>Q4,0.10,0.01,1,STRCAT('◆A: ',STRCAT(CON2STR(OA周,0),'周')))COLOR00FF00;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(Q5)>Q4,0.10,0.08,1,STRCAT(' A―B: ',STRCAT(CON2STR(AB周,0),'周')))COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(Q5)>Q4,0.10,0.16,1,STRCAT(' B―C: ',STRCAT(CON2STR(BC周,0),'周')))COLOR00FF00;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(Q5)>Q4,0.10,0.24,1,STRCAT('C---: ',STRCAT(CON2STR(Q3,0),'周')))COLORYELLOW;
{123周期}
Z01:=Q1-Q0+1;Z12:=Q0-Q3+1;Z23:=Q3-Q2+1;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(Q5)<Q4,0.10,0.01,1,STRCAT('◎―1: ',STRCAT(CON2STR(Z01,0),'周')))COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(Q5)<Q4,0.10,0.08,1,STRCAT('1―2: ',STRCAT(CON2STR(Z12,0),'周')))COLOR00FF00;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(Q5)<Q4,0.10,0.16,1,STRCAT('2―3: ',STRCAT(CON2STR(Z23,0),'周')))COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(Q5)<Q4,0.10,0.24,1,STRCAT('3---  : ',STRCAT(CON2STR(Q2,0),'周')))COLORYELLOW;

低一:REF(L,BARSLAST(VV)),DOTLINE,COLOR99FF66;
高一:REF(H,BARSLAST(VV2)),DOTLINE,COLOR99FF66;
低二:REF(L,BARSLAST(XX)),DOTLINE,COLORFF66FF;
高二:REF(H,BARSLAST(XX2)),DOTLINE,COLORFF66FF;
ABC:IF(Q5>Q4,REF(L,BARSLAST(XXQ)),0),DOTLINE,COLORCYAN;
①②③:IF(Q5<Q4,REF(H,BARSLAST(XX3Q)),0),DOTLINE,COLORCYAN;

{ABC涨跌}
OA幅:=(低二-高二)/低二*100;AB幅:=(高一-低二)/低二*100;BC幅:=(低一-高一)/高一*100;AO幅:=(C-低一)/C*100;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(Q5)>Q4,0.14,0.01,0,STRCAT('跌',STRCAT(CON2STR(OA幅,0),'%')))COLOR00FF00;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(Q5)>Q4,0.14,0.08,0,STRCAT('涨',STRCAT(CON2STR(AB幅,0),'%')))COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(Q5)>Q4,0.14,0.16,0,STRCAT('跌',STRCAT(CON2STR(BC幅,0),'%')))COLOR00FF00;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(Q5)>Q4,0.14,0.24,0,STRCAT('涨',STRCAT(CON2STR(AO幅,0),'%')))COLORYELLOW;
{123涨跌}
D01:=(高二-低二)/低二*100;D12:=(低一-高二)/低一*100;D23:=(高一-低一)/低一*100;D30:=(C-高一)/C*100;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(Q5)<Q4,0.14,0.01,0,STRCAT('涨',STRCAT(CON2STR(D01,0),'%')))COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(Q5)<Q4,0.14,0.08,0,STRCAT('跌',STRCAT(CON2STR(D12,0),'%')))COLOR00FF00;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(Q5)<Q4,0.14,0.16,0,STRCAT('涨',STRCAT(CON2STR(D23,0),'%')))COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(Q5)<Q4,0.14,0.24,0,STRCAT('跌',STRCAT(CON2STR(D30,0),'%')))COLORYELLOW;
笔:DRAWLINE(J2,IF(HD,H,L),BARSTATUS=2,IF(BARSLAST(HD)>BARSLAST(LD),H,L),0),DOTLINE,COLORYELLOW,LINETHICK1;
{近半分位:高一-(高一-低一)*(0.01*半分位),COLOR99FF66;}
近半分位:低一-(低一-高一)*(0.01*半分位),COLOR99FF66;
STICKLINE(VV,高一,低一,0,1),COLOR99FF66;
STICKLINE(VV2 ,高一,低一,0,0),COLOR99FF66;
DRAWTEXT( VV=1 AND Q0>Q1,L,'C')COLORMAGENTA;
DRAWTEXT(VV2=1 AND Q0>Q1,H,'B')COLORMAGENTA;
DRAWTEXT( XX=1 AND Q0>Q1,L,'A')COLORMAGENTA;
DRAWTEXT(XX2=1 AND Q5>Q4 ,H,'◆')COLORMAGENTA;
DRAWTEXT(XXQ=1 AND Q5>Q4 ,L,'★')COLORMAGENTA;

DRAWTEXT( VV=1 AND Q0<Q1,L,'②')COLORMAGENTA;
DRAWTEXT(VV2=1 AND Q0<Q1,H,'③')COLORMAGENTA;
DRAWTEXT(XX2=1 AND Q0<Q1,H,'①')COLORMAGENTA;
DRAWTEXT(XX=1  AND Q5<Q4,L,'◎')COLORMAGENTA;
DRAWTEXT(XX3Q=1  AND Q5<Q4,H,'☆')COLORMAGENTA;

V00:= HIGH<REF(HIGH,1) AND LOW<REF(LOW,1);
V01:= HIGH<REF(HIGH,1) AND LOW>REF(LOW,1);
V02:= HIGH>REF(HIGH,1) AND LOW<REF(LOW,1);
V03:= HIGH>REF(HIGH,1) AND LOW>REF(LOW,1);
V04:= REF(HIGH,2) < HIGH AND REF(LOW,2) < LOW AND REF(HIGH,2) > REF(HIGH,1) AND REF(LOW,2) < REF(LOW,1);
V1:= COUNT(V00,3)>=1 AND LLVBARS(LOW,3) = 1 AND V03;
V2:= COUNT(V00,4)>=1 AND LLVBARS(LOW,4) = 2 AND V04;
V3:= COUNT(V00,4)>=1 AND COUNT(V01 OR V02,4)=1 AND LLVBARS(LOW,4) = 1 AND V03;
V4:= COUNT(V00,5)>=1 AND COUNT(V01 OR V02,5)=2 AND LLVBARS(LOW,5) = 2 AND V04;
XG1:= V1 OR V2 OR V3 OR V4;
XG2:= C > REF(HIGH,1);
XG:=XG1 AND XG2;
一阳定势:CROSS(C,高一) AND CROSS(C,高二) AND CROSS(C,①②③),COLORYELLOW,NODRAW;
STICKLINE(一阳定势,OPEN,CLOSE,2.8,1),COLORMAGENTA;
DRAWTEXT(一阳定势=1,L,'一阳定势'),COLORYELLOW;
收敛:ABC>0 AND ABC<低二 AND 低二<低一 AND 高二>高一 AND CROSS(C,上轨1);
STICKLINE(收敛,OPEN,CLOSE,2.8,1),COLORMAGENTA;
DRAWTEXT(收敛=1,L,'收敛'),COLORYELLOW;
强势:ABC>0 AND ABC<低二 AND 低二<低一 AND 高二<高一 AND CROSS(C,高一);
STICKLINE(强势,OPEN,CLOSE,2.8,1),COLORMAGENTA;
DRAWTEXT(强势=1,L,'强势'),COLORYELLOW;
三买:(低一>高二 AND 近半分位>低一 AND XG>0 AND C>O),COLORYELLOW,NODRAW;
STICKLINE(三买,OPEN,CLOSE,2.8,1),COLORMAGENTA;
DRAWTEXT(三买=1,L,'三买'),COLORYELLOW;
{涨停向右画线}
涨停线:REF(L+(H-L)*(0.01*涨停位),BARSLAST(CONST(BARSLAST(IF(CURRBARSCOUNT<=390*日线,涨停,0)))+1=CURRBARSCOUNT)),DOTLINE,COLORYELLOW;
涨停幅:(L-涨停线)/涨停线*100,NODRAW;


{C>REF(C,1)*1.097,0}
{◎ ①②③④⑤⑥⑦⑧⑨⑩ Α★☆? A●◎ABCDEFGHIJKLMN};
[/lycode]

123战法 解释
[lycode=tdx,true]智能版赋值:"炒股叉|WWW.CHAOGUX.COM的核心[取日线数据]"
输出MA1:收盘价的M1日简单移动平均,画白色
输出均线:收盘价的M2日简单移动平均,画黄色
输出MA3:收盘价的M3日简单移动平均,画青色
输出MA4:收盘价的M4日简单移动平均,画青色
输出成本:((获利盘为90%的成本分布+获利盘为70%的成本分布+获利盘为50%的成本分布+获利盘为30%的成本分布+获利盘为10%的成本分布)/5)*成本线,线宽为2,画白色
当满足条件收盘价*成本线>=开盘价时,在收盘价和最高价位置之间画柱状线,宽度为0,0不为0则画空心柱., 画红色
当满足条件收盘价*成本线>=开盘价时,在开盘价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱., 画红色
当满足条件收盘价<开盘价*成本线时,在开盘价和最高价位置之间画柱状线,宽度为0,0不为0则画空心柱., COLOR00EC00
当满足条件收盘价<开盘价*成本线时,在收盘价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱., COLOR00EC00
当满足条件收盘价*成本线>=开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为2.9.2,0不为0则画空心柱.,COLOR0000A1
当满足条件收盘价*成本线>=开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为1.9.2,0不为0则画空心柱.,COLOR0000B5
当满足条件收盘价*成本线>=开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为0.9.8,0不为0则画空心柱.,COLOR0000C5
当满足条件收盘价*成本线>=开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为0.4,0不为0则画空心柱.,COLOR0000D4
当满足条件收盘价*成本线>=开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为0.2,0不为0则画空心柱.,COLOR0000FF
当满足条件收盘价<开盘价*成本线时,在收盘价和开盘价位置之间画柱状线,宽度为2.9.2,0不为0则画空心柱.,COLOR009000
当满足条件收盘价<开盘价*成本线时,在收盘价和开盘价位置之间画柱状线,宽度为1.9.2,0不为0则画空心柱.,COLOR00B400
当满足条件收盘价<开盘价*成本线时,在收盘价和开盘价位置之间画柱状线,宽度为0.9.8,0不为0则画空心柱.,COLOR00C100
当满足条件收盘价<开盘价*成本线时,在收盘价和开盘价位置之间画柱状线,宽度为0.4,0不为0则画空心柱.,COLOR00DB00
当满足条件收盘价<开盘价*成本线时,在收盘价和开盘价位置之间画柱状线,宽度为0.2,0不为0则画空心柱.,COLOR00EC00
日线赋值:如果周期类型=5,返回1,否则返回0
CA3赋值:1日前的收盘价*日线
涨停赋值:如果(收盘价-CA3)*100/CA3>=(10-0.01*100/CA3),返回1,否则返回0
当满足条件涨停时,在开盘价和收盘价位置之间画柱状线,宽度为2.9.1,1不为0则画空心柱.,画黄色
跌停赋值:如果(CA3-收盘价)*100/CA3>=(10-0.01*100/CA3),返回1,否则返回0
当满足条件跌停时,在开盘价和收盘价位置之间画柱状线,宽度为2.9.1,0不为0则画空心柱.,画青色
A1赋值:3日前的最高价=笔周期*3+1日内最高价的最高值*智能版
B1赋值:A1的3日过滤
C1赋值:若B1则将最近3+1周期置为1
D1赋值:C1的3日过滤
A2赋值:3日前的最低价=笔周期*3+1日内最低价的最低值*智能版
B2赋值:A2的3日过滤
C2赋值:若B2则将最近3+1周期置为1
D2赋值:C2的3日过滤
E1赋值:(1日前的2*3日内最低价的最低值+1日前的2*3日内最高价的最高值)/2
E2赋值:(最高价+最低价)/2
H1赋值:(D1 AND 取反) OR 数据位置状态=2 OR 收盘价的有效数据周期数=1
H2赋值:D1 AND 取反
L1赋值:D2 AND 取反
X1赋值:1日前的上次H1距今天数+1
F1赋值:若H1ANDCOUNT(L1,X1)>0则将最近X1日内如果L1,返回最低价,否则返回10000距今天数周期置为1
G1赋值:F1>1日前的F1
I1赋值:若G1则将最近2周期置为1
LD赋值:I1>1日前的I1
L2赋值:LD OR 数据位置状态=2 OR 收盘价的有效数据周期数=1
X2赋值:1日前的上次L2距今天数+1
F2赋值:若L2ANDCOUNT(H2,X2)>0则将最近X2日内如果H2,返回最高价,否则返回0距今天数周期置为1
G2赋值:F2>1日前的F2
I2赋值:若G2则将最近2周期置为1
HD赋值:I2>1日前的I2
当满足条件LD时,在最低价位置画直线起点,当满足条件HD时,在最高价位置画直线终点,0表示是否延长.,画黄色,线宽为1
当满足条件HD时,在最高价位置画直线起点,当满足条件LD时,在最低价位置画直线终点,0表示是否延长.,画黄色,线宽为1
J1赋值:若数据位置状态=2则将最近上次HD距今天数和上次LD距今天数的较小值+1周期置为1
J2赋值:J1>1日前的J1
A3赋值:最高价
B3赋值:1日前的上次HD距今天数+1日前的最高价>1日前的上次HD距今天数+2+1日前的上次HD距今天数+2日前的上次HD距今天数日前的最高价
D3赋值:A3 AND B3 AND HD
E3赋值:若D3则将最近1日前的上次HD距今天数+2周期置为1
HH赋值:E3>1日前的E3
A4赋值:最低价>1日前的上次LD距今天数+1日前的最低价
B4赋值:1日前的上次LD距今天数+1日前的最低价
D4赋值:A4 AND B4 AND LD
E4赋值:若D4则将最近1日前的上次LD距今天数+2周期置为1
LL赋值:E4>1日前的E4
H3赋值:HH OR 数据位置状态=2 OR 收盘价的有效数据周期数=1
X3赋值:1日前的上次H3距今天数+1
F3赋值:若H3ANDCOUNT(LL,X3)>0则将最近X3日内如果LL,返回最低价,否则返回10的20乘幂距今天数周期置为1
G3赋值:F3>1日前的F3
I3赋值:若G3则将最近2周期置为1
LZ赋值:I3>1日前的I3
L4赋值:LZ OR 数据位置状态=2 OR 收盘价的有效数据周期数=1
X4赋值:1日前的上次L4距今天数+1
F4赋值:若L4ANDCOUNT(HH,X4)>0则将最近X4日内如果HH,返回最高价,否则返回-10的20乘幂距今天数周期置为1
G4赋值:F4>1日前的F4
I4赋值:若G4则将最近2周期置为1
HZ赋值:I4>1日前的I4
K1赋值:若数据位置状态=2则将最近上次HZ距今天数和上次LZ距今天数的较小值+1周期置为1
K2赋值:K1>1日前的K1
UU赋值:若数据位置状态=2则将最近上次LD距今天数+1周期置为1
VV赋值:UU>1日前的UU
WW赋值:若VV则将最近1日前的上次LD距今天数+2周期置为1
XX赋值:WW>1日前的WW
WWQ赋值:若XX则将最近1日前的上次LD距今天数+2周期置为1
XXQ赋值:WWQ>1日前的WWQ
输出下轨:当满足条件XX时,在最低价位置画直线起点,当满足条件VV时,在最低价位置画直线终点,1表示是否延长.*画趋势,画洋红色,线宽为1
UU2赋值:若数据位置状态=2则将最近上次HD距今天数+1周期置为1
VV2赋值:UU2>1日前的UU2
WW2赋值:若VV2则将最近1日前的上次HD距今天数+2周期置为1
XX2赋值:WW2>1日前的WW2
WW3Q赋值:若XX2则将最近1日前的上次HD距今天数+2周期置为1
XX3Q赋值:WW3Q>1日前的WW3Q
WW4Q赋值:若XX3Q则将最近1日前的上次HD距今天数+2周期置为1
XX4Q赋值:WW4Q>1日前的WW4Q
输出上轨:当满足条件XX2时,在最高价位置画直线起点,当满足条件VV2时,在最高价位置画直线终点,1表示是否延长.*画趋势,画洋红色,线宽为1
上轨1赋值:当满足条件XX2时,在最高价位置画直线起点,当满足条件VV2时,在最高价位置画直线终点,1表示是否延长.
Q0赋值:上次XX2>0距今天数
Q1赋值:上次XX>0距今天数
Q2赋值:上次WW2>0距今天数
Q3赋值:上次VV>0距今天数
Q4赋值:上次XXQ>0距今天数
Q5赋值:上次XX3Q>0距今天数
Q6赋值:上次XX4Q>0距今天数
OA周赋值:Q0-Q1+1
AB周赋值:Q1-Q2+1
BC周赋值:Q2-Q3+1
当满足条件到最后交易的周期=1AND(Q5)>Q4时,在横轴0.10纵轴0.01位置书写文字COLOR00FF00
当满足条件到最后交易的周期=1AND(Q5)>Q4时,在横轴0.10纵轴0.08位置书写文字画红色
当满足条件到最后交易的周期=1AND(Q5)>Q4时,在横轴0.10纵轴0.16位置书写文字COLOR00FF00
当满足条件到最后交易的周期=1AND(Q5)>Q4时,在横轴0.10纵轴0.24位置书写文字画黄色
Z01赋值:Q1-Q0+1
Z12赋值:Q0-Q3+1
Z23赋值:Q3-Q2+1
当满足条件到最后交易的周期=1AND(Q5)<Q4时,在横轴0.10纵轴0.01位置书写文字画红色
当满足条件到最后交易的周期=1AND(Q5)<Q4时,在横轴0.10纵轴0.08位置书写文字COLOR00FF00
当满足条件到最后交易的周期=1AND(Q5)<Q4时,在横轴0.10纵轴0.16位置书写文字画红色
当满足条件到最后交易的周期=1AND(Q5)<Q4时,在横轴0.10纵轴0.24位置书写文字画黄色
输出低一:上次VV距今天数日前的最低价,DOTLINE,COLOR99FF66
输出高一:上次VV2距今天数日前的最高价,DOTLINE,COLOR99FF66
输出低二:上次XX距今天数日前的最低价,DOTLINE,COLORFF66FF
输出高二:上次XX2距今天数日前的最高价,DOTLINE,COLORFF66FF
输出ABC:如果Q5>Q4,返回上次XXQ距今天数日前的最低价,否则返回0,DOTLINE,画青色
输出①②③:如果Q5<Q4,返回上次XX3Q距今天数日前的最高价,否则返回0,DOTLINE,画青色
OA幅赋值:(低二-高二)/低二*100
AB幅赋值:(高一-低二)/低二*100
BC幅赋值:(低一-高一)/高一*100
AO幅赋值:(收盘价-低一)/收盘价*100
当满足条件到最后交易的周期=1AND(Q5)>Q4时,在横轴0.14纵轴0.01位置书写文字COLOR00FF00
当满足条件到最后交易的周期=1AND(Q5)>Q4时,在横轴0.14纵轴0.08位置书写文字画红色
当满足条件到最后交易的周期=1AND(Q5)>Q4时,在横轴0.14纵轴0.16位置书写文字COLOR00FF00
当满足条件到最后交易的周期=1AND(Q5)>Q4时,在横轴0.14纵轴0.24位置书写文字画黄色
D01赋值:(高二-低二)/低二*100
D12赋值:(低一-高二)/低一*100
D23赋值:(高一-低一)/低一*100
D30赋值:(收盘价-高一)/收盘价*100
当满足条件到最后交易的周期=1AND(Q5)<Q4时,在横轴0.14纵轴0.01位置书写文字画红色
当满足条件到最后交易的周期=1AND(Q5)<Q4时,在横轴0.14纵轴0.08位置书写文字COLOR00FF00
当满足条件到最后交易的周期=1AND(Q5)<Q4时,在横轴0.14纵轴0.16位置书写文字画红色
当满足条件到最后交易的周期=1AND(Q5)<Q4时,在横轴0.14纵轴0.24位置书写文字画黄色
输出笔:当满足条件J2时,在如果HD,返回最高价,否则返回最低价位置画直线起点,当满足条件数据位置状态=2时,在如果上次HD距今天数>上次LD距今天数,返回最高价,否则返回最低价位置画直线终点,0表示是否延长.,DOTLINE,画黄色,线宽为1
输出近半分位:低一-(低一-高一)*(0.01*半分位),COLOR99FF66
当满足条件VV时,在高一和低一位置之间画柱状线,宽度为0,1不为0则画空心柱.,COLOR99FF66
当满足条件VV2时,在高一和低一位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR99FF66
当满足条件VV=1ANDQ0>Q1时,在最低价位置书写文字画洋红色
当满足条件VV2=1ANDQ0>Q1时,在最高价位置书写文字画洋红色
当满足条件XX=1ANDQ0>Q1时,在最低价位置书写文字画洋红色
当满足条件XX2=1ANDQ5>Q4时,在最高价位置书写文字画洋红色
当满足条件XXQ=1ANDQ5>Q4时,在最低价位置书写文字画洋红色
当满足条件VV=1ANDQ0<Q1时,在最低价位置书写文字画洋红色
当满足条件VV2=1ANDQ0<Q1时,在最高价位置书写文字画洋红色
当满足条件XX2=1ANDQ0<Q1时,在最高价位置书写文字画洋红色
当满足条件XX=1ANDQ5<Q4时,在最低价位置书写文字画洋红色
当满足条件XX3Q=1ANDQ5<Q4时,在最高价位置书写文字画洋红色
V00赋值: 最高价<1日前的最高价 AND 最低价<1日前的最低价
V01赋值: 最高价<1日前的最高价 AND 最低价>1日前的最低价
V02赋值: 最高价>1日前的最高价 AND 最低价<1日前的最低价
V03赋值: 最高价>1日前的最高价 AND 最低价>1日前的最低价
V04赋值: 2日前的最高价 < 最高价 AND 2日前的最低价 < 最低价 AND 2日前的最高价 > 1日前的最高价 AND 2日前的最低价 < 1日前的最低价
V1赋值: 统计3日中满足V00的天数>=1 AND 3日内最低价距今天数 = 1 AND V03
V2赋值: 统计4日中满足V00的天数>=1 AND 4日内最低价距今天数 = 2 AND V04
V3赋值: 统计4日中满足V00的天数>=1 AND 统计4日中满足V01ORV02的天数=1 AND 4日内最低价距今天数 = 1 AND V03
V4赋值: 统计5日中满足V00的天数>=1 AND 统计5日中满足V01ORV02的天数=2 AND 5日内最低价距今天数 = 2 AND V04
XG1赋值: V1 OR V2 OR V3 OR V4
XG2赋值: 收盘价 > 1日前的最高价
XG赋值:XG1 AND XG2
输出一阳定势:收盘价上穿高一 AND 收盘价上穿高二 AND 收盘价上穿①②③,画黄色,NODRAW
当满足条件一阳定势时,在开盘价和收盘价位置之间画柱状线,宽度为2.8,1不为0则画空心柱.,画洋红色
当满足条件一阳定势=1时,在最低价位置书写文字,画黄色
输出收敛:ABC>0 AND ABC<低二 AND 低二<低一 AND 高二>高一 AND 收盘价上穿上轨1
当满足条件收敛时,在开盘价和收盘价位置之间画柱状线,宽度为2.8,1不为0则画空心柱.,画洋红色
当满足条件收敛=1时,在最低价位置书写文字,画黄色
输出强势:ABC>0 AND ABC<低二 AND 低二<低一 AND 高二<高一 AND 收盘价上穿高一
当满足条件强势时,在开盘价和收盘价位置之间画柱状线,宽度为2.8,1不为0则画空心柱.,画洋红色
当满足条件强势=1时,在最低价位置书写文字,画黄色
输出三买:(低一>高二 AND 近半分位>低一 AND XG>0 AND 收阳线),画黄色,NODRAW
当满足条件三买时,在开盘价和收盘价位置之间画柱状线,宽度为2.8,1不为0则画空心柱.,画洋红色
当满足条件三买=1时,在最低价位置书写文字,画黄色
输出涨停线:上次上次如果到最后交易的周期<=390*日线,返回涨停,否则返回0距今天数的最后一日取值设为常数+1=到最后交易的周期距今天数日前的最低价+(最高价-最低价)*(0.01*涨停位),DOTLINE,画黄色
输出涨停幅:(最低价-涨停线)/涨停线*100,NODRAW
[/lycode]

其他几个指标请下载导入观看
下载地址:
游客,如果您要查看本帖隐藏内容请回复


看了该指标的人还看了:
分时攻击力度指标    低位股票指标
必胜客指标    五彩周J指标

举报 使用道具

回复

精彩评论55

Bergwind  新手上路

发表于 2017-9-21 22:02:15 | 显示全部楼层

看看,很神秘ide样子

举报 使用道具

回复

tschin46  新手上路

发表于 2018-1-29 12:49:25 | 显示全部楼层

举报 使用道具

回复

zhaofeng0601  新手上路

发表于 2018-5-16 22:17:15 | 显示全部楼层

组合成交量

举报 使用道具

回复

炳垚  注册会员

发表于 2018-5-17 08:51:25 | 显示全部楼层

很想了解

举报 使用道具

回复

z3307  新手上路

发表于 2018-5-18 12:37:08 | 显示全部楼层

zhiyuma  hai yao huifu

举报 使用道具

回复

孤风竹影  新手上路

发表于 2018-5-19 08:37:19 | 显示全部楼层

6666666666

举报 使用道具

回复

QAZWSX  注册会员

发表于 2018-5-22 20:33:53 | 显示全部楼层

ZAN ZANZANZANZANZAN

举报 使用道具

回复

zxpkiddy  高级会员

发表于 2018-5-27 22:11:34 | 显示全部楼层

学习学习学习学习

举报 使用道具

回复

ppdd  新手上路

发表于 2018-5-28 21:00:26 | 显示全部楼层

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表